# Upgrade Assistant - Critical Errors!

**URL:** <https://discuss.elastic.co/t/upgrade-assistant-critical-errors/327650>\
**Category:** Kibana\
**Created:** [March 14, 2023, 10:37am UTC](https://discuss.elastic.co/t/upgrade-assistant-critical-errors/327650 "2023-03-14T10:37:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Arunaps](https://avatars.discourse-cdn.com/v4/letter/a/a9adbd/32.png) [@Arunaps](https://discuss.elastic.co/u/Arunaps)\
**Post date:** [March 14, 2023, 10:37am UTC](https://discuss.elastic.co/t/upgrade-assistant-critical-errors/327650/1 "2023-03-14T10:37:18Z")

</div>

Hi,

We are trying to upgrade our ELK from 7.17 to 8.6 using upgrade Assistant.  
It is showing critical alert in Kibana and as follows:-

Configuring the "container ID" field has been deprecated and will be removed in 8.0.0. This plugin is designed to work with ECS, and expects this field to have a value of `container.id`. It has a different value configured in Source Configuration: Default

### How to fix (provided by Upgrade assistant)

Adjust your indexing to identify Docker containers using "container.id".

I tried to check my indices and saw we are using "container.id" only.

Any help would be much appreciated

---

<div class="post-metadata">

**Author:** ![Arunaps](https://avatars.discourse-cdn.com/v4/letter/a/a9adbd/32.png) [@Arunaps](https://discuss.elastic.co/u/Arunaps)\
**Post date:** [March 16, 2023, 3:11pm UTC](https://discuss.elastic.co/t/upgrade-assistant-critical-errors/327650/2 "2023-03-16T15:11:17Z")

</div>

Issue resolved

* * *

Observability --\> Metrics ---\> settings ----\> change the docker.container.id to container.id

If you are getting same error for host.name do the same.

Observability --\> Metrics ---\> settings ----\> change the host to host.name

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 13, 2023, 3:11pm UTC](https://discuss.elastic.co/t/upgrade-assistant-critical-errors/327650/3 "2023-04-13T15:11:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
