# Upgrade Assistant: Internal Server Error

**URL:** https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955
**Category:** Kibana
**Created:** [March 2, 2021, 12:27pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955 "2021-03-02T12:27:29Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![adsr](https://avatars.discourse-cdn.com/v4/letter/a/e95f7d/32.png) [@adsr](https://discuss.elastic.co/u/adsr)
#### Post date: [March 2, 2021, 12:27pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955/1 "2021-03-02T12:27:29Z")

</div>

Hello everyone,

after upgrading to 7.11.1 (coming from 7.5.0) I notice that the "Upgrade Assistant" reports an Internal Server Error:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/3/b3a00c606bae0043a6c4e923902da9d27dfd7af3.png)

I tried starting kibana with `logging.verbose: true` but can't seem to see any "useful" information:

```auto
GET /api/upgrade_assistant/status

Error: Internal Server Error
    at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:121:19)
    at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:75:19)
    at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:70:17)
    at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:164:34)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)
    at module.exports.internals.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:45:28)
    at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)
    at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)
    at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:312:32)
    at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:221:9)

```

The request appears to return a

```auto
{"statusCode":500,"error":"Internal Server Error","message":"Cannot read property 'level' of undefined"}

```

Thanks for input.

---

<div class="post-metadata">

### Author: ![afharo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/afharo/32/75202_2.png) [@afharo](https://discuss.elastic.co/u/afharo)
#### Post date: [March 3, 2021, 12:28pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955/2 "2021-03-03T12:28:07Z")

</div>

Hi @adsr,

It looks like a bug to me. I've created [The Upgrade Assistant shows Internal Server · Issue #93408 · elastic/kibana · GitHub](https://github.com/elastic/kibana/issues/93408) for the team to track a fix. Would you mind following in there and adding any additional context I might have missed when creating the issue?

Thank you!

---

<div class="post-metadata">

### Author: ![adsr](https://avatars.discourse-cdn.com/v4/letter/a/e95f7d/32.png) [@adsr](https://discuss.elastic.co/u/adsr)
#### Post date: [March 3, 2021, 1:12pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955/3 "2021-03-03T13:12:45Z")

</div>

Hi @afharo,  
thanks for your input. I will gladly do so!

I guess this here can be closed then.

BR

---

<div class="post-metadata">

### Author: ![afharo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/afharo/32/75202_2.png) [@afharo](https://discuss.elastic.co/u/afharo)
#### Post date: [March 3, 2021, 2:34pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955/4 "2021-03-03T14:34:28Z")

</div>



---

<div class="post-metadata">

### Author: ![alisongoryachev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alisongoryachev/32/111352_2.png) [@alisongoryachev](https://discuss.elastic.co/u/alisongoryachev)
#### Post date: [March 3, 2021, 4:03pm UTC](https://discuss.elastic.co/t/upgrade-assistant-internal-server-error/265955/5 "2021-03-03T16:03:25Z")

</div>

Hi @adsr! I've responded to the GitHub issue asking for additional information. I do not know your GH handle so I was not able to tag you. Can you respond there when you get a chance? Thanks!
