# Upgrade elasticsearch from 6.5 to 6.8.1

**URL:** https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182
**Category:** Elasticsearch
**Created:** [July 18, 2019, 11:01am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182 "2019-07-18T11:01:17Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Hitesh\_Malhotra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hitesh_malhotra/32/50434_2.png) [@Hitesh\_Malhotra](https://discuss.elastic.co/u/Hitesh_Malhotra)
#### Post date: [July 18, 2019, 11:01am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182/1 "2019-07-18T11:01:17Z")

</div>

Hi ,  
I am trying to upgrade elastic from 6.5 to 6.8.1 by using  
sudo yum install elasticsearch command but no luck

```
Loaded plugins: fastestmirror, product-id, search-disabled-repos, subscription-manager
    This system is not registered with an entitlement server. You can use subscription-manager to register.
    Loading mirror speeds from cached hostfile
     * epel: repos.del.extreme-ix.org
    http://ftp.heanet.ie/pub/centos/7.5.1804/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror.
    To address this issue please refer to the below wiki article

    https://wiki.centos.org/yum-errors

    If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

    Resolving Dependencies
    --> Running transaction check
    ---> Package elasticsearch.noarch 0:6.5.0-1 will be updated
    ---> Package elasticsearch.noarch 0:6.8.1-1 will be an update
    --> Finished Dependency Resolution

    Dependencies Resolved

    =========================================================================================================================================
     Package Arch Version Repository Size
    =========================================================================================================================================
    Updating:
     elasticsearch noarch 6.8.1-1 kibana-6.x 142 M

    Transaction Summary
    =========================================================================================================================================
    Upgrade 1 Package

    Total download size: 142 M
    Is this ok [y/d/N]: y
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    elasticsearch-6.8.1.rpm | 142 MB 00:00:03
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    could not find java; set JAVA_HOME
    error: %pre(elasticsearch-0:6.8.1-1.noarch) scriptlet failed, exit status 1
    Error in PREIN scriptlet in rpm package elasticsearch-6.8.1-1.noarch
    elasticsearch-6.5.0-1.noarch was supposed to be removed but is not!
      Verifying : elasticsearch-6.5.0-1.noarch 1/2
      Verifying : elasticsearch-6.8.1-1.noarch 2/2

    Failed:
      elasticsearch.noarch 0:6.5.0-1 elasticsearch.noarch 0:6.8.1-1
```

---

<div class="post-metadata">

### Author: ![Hitesh\_Malhotra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hitesh_malhotra/32/50434_2.png) [@Hitesh\_Malhotra](https://discuss.elastic.co/u/Hitesh_Malhotra)
#### Post date: [July 19, 2019, 4:52am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182/2 "2019-07-19T04:52:21Z")

</div>

Hey,

can anybody help me ?

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 19, 2019, 6:32am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182/3 "2019-07-19T06:32:48Z")

</div>

Read [this](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and specifically the "Also be patient" part.

It's fine to answer on your own thread after 2 or 3 days (not including weekends) if you don't have an answer.

---

<div class="post-metadata">

### Author: ![Hitesh\_Malhotra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hitesh_malhotra/32/50434_2.png) [@Hitesh\_Malhotra](https://discuss.elastic.co/u/Hitesh_Malhotra)
#### Post date: [July 19, 2019, 7:16am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182/4 "2019-07-19T07:16:46Z")

</div>

Thanks David

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 16, 2019, 7:16am UTC](https://discuss.elastic.co/t/upgrade-elasticsearch-from-6-5-to-6-8-1/191182/5 "2019-08-16T07:16:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
