# Upgrade failed to 8.x

**URL:** <https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665>\
**Category:** Elasticsearch\
**Created:** [June 22, 2023, 10:13am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665 "2023-06-22T10:13:58Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chel/32/49777_2.png) [@Chel](https://discuss.elastic.co/u/Chel)\
**Post date:** [June 22, 2023, 10:13am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/1 "2023-06-22T10:13:58Z")

</div>

Error message: Upgrading the 7.17.4 ES version to 8.5.2 ES cluster getting the below message. We have checked the deprecation messages and upgrade assistant and nothing was reported.

java.lang.IllegalStateException: cannot upgrade node because incompatible indices created with version [6.4.3] exist, while the minimum compatible index version is [7.0.0]. Upgrade your older indices by reindexing them in version [7.17.0] first.

AS per below article i am downgrading to 7.17.4 but not sure whether it will come up fine as index metadata might be changed or corrupted. Also master node not discovered exception we are getting while downgrading to 7.17 and \_cat/indices is not working.

> [@Upgraded first node from 7.17.5 to 8.4. Won't start, claiming there is a 6.4.5 index, but I can't find it](https://discuss.elastic.co/t/upgraded-first-node-from-7-17-5-to-8-4-wont-start-claiming-there-is-a-6-4-5-index-but-i-cant-find-it/317811/9):
>
> Thanks for the tip, Emily! I'll give that a try with this node as well and see how it goes. 100% agree that the Error message would be more useful if it listed the problematic indices.

---

<div class="post-metadata">

**Author:** ![Chel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chel/32/49777_2.png) [@Chel](https://discuss.elastic.co/u/Chel)\
**Post date:** [June 22, 2023, 10:35am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/3 "2023-06-22T10:35:31Z")

</div>

Cluster came up after downgrade to 7.17.4. How to check the index version got updated to 7.17.4 from 6.4.3? Any other steps needed for that refresh?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 22, 2023, 10:42am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/4 "2023-06-22T10:42:00Z")

</div>

Run the migration assistant in Kibana if you have not already. You will need to reindex any indices created under ES 6.x before you can migrate to ES 8.x.

---

<div class="post-metadata">

**Author:** ![Chel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chel/32/49777_2.png) [@Chel](https://discuss.elastic.co/u/Chel)\
**Post date:** [June 22, 2023, 10:55am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/5 "2023-06-22T10:55:24Z")

</div>

upgrading to 7.17.4 doesn't change the index version to 7.x. Is this a bug? We have not directly migrated from 6.4 to 8.5 though

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 22, 2023, 10:58am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/6 "2023-06-22T10:58:29Z")

</div>

> [@Chel](#):
>
> upgrading to 7.17.4 doesn't change the index version to 7.x.

Not for old indices. This might require you to make decisions, so can not necessarily be done automatically. There is some functionality [allowing you to read older indices](https://www.elastic.co/guide/en/elasticsearch/reference/8.8/setup-upgrade.html) but I have not used it.

---

<div class="post-metadata">

**Author:** ![Chelambarasan\_CR](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chelambarasan_cr/32/62592_2.png) [@Chelambarasan\_CR](https://discuss.elastic.co/u/Chelambarasan_CR)\
**Post date:** [June 26, 2023, 4:31am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/7 "2023-06-26T04:31:25Z")

</div>

Thanks. Is there a way to check the index metadata version ? We have roll back to 7.17.4 and like to know to check for index metadata version of it is changed to 7.x or still in 6.x which needs reindexing ?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 26, 2023, 4:35am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/8 "2023-06-26T04:35:16Z")

</div>

I recommend you run the [Kibana Upgrade Assistant](https://www.elastic.co/guide/en/kibana/7.17/upgrade-assistant.html).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 24, 2023, 4:35am UTC](https://discuss.elastic.co/t/upgrade-failed-to-8-x/336665/9 "2023-07-24T04:35:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
