# Upgrade from 5.6.5 to 6.3.2 elasticsearch fails due to "Caused by: java.lang.IllegalStateException: unexpected distribution flavor \[\]; your distribution is broken"

**URL:** <https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147>\
**Category:** Elasticsearch\
**Created:** [September 19, 2018, 3:01pm UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147 "2018-09-19T15:01:52Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![vijayakumar.balraj](https://avatars.discourse-cdn.com/v4/letter/v/e5b9ba/32.png) [@vijayakumar.balraj](https://discuss.elastic.co/u/vijayakumar.balraj)\
**Post date:** [September 19, 2018, 3:01pm UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147/1 "2018-09-19T15:01:52Z")

</div>

am trying to upgrade elasticsearch version from 5.6.5 to 6.3.2 in centos7 OS and am seeing below error

[2018-09-19T14:52:15,414][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [ips-estestupgrade] fatal error in thread [main], exiting

java.lang.ExceptionInInitializerError: null

at org.elasticsearch.common.logging.DeprecationLogger.\<clinit\>(DeprecationLogger.java:164) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.common.unit.ByteSizeValue.\<clinit\>(ByteSizeValue.java:39) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.http.HttpTransportSettings.\<clinit\>(HttpTransportSettings.java:84) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Security.addSocketPermissionForHttp(Security.java:342) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Security.addBindPermissions(Security.java:329) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:254) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Security.configure(Security.java:122) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:208) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.3.1.jar:6.3.1]

at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.3.1.jar:6.3.1]

Caused by: java.lang.IllegalStateException: unexpected distribution flavor []; your distribution is broken

at org.elasticsearch.Build$Flavor.fromDisplayName(Build.java:69) ~[elasticsearch-6.3.1.jar:6.3.1]

at org.elasticsearch.Build.\<clinit\>(Build.java:118) ~[elasticsearch-6.3.1.jar:6.3.1]

... 16 more

please help to fix the above problem

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [September 19, 2018, 5:24pm UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147/2 "2018-09-19T17:24:02Z")

</div>

How did you install elasticsearch?

---

<div class="post-metadata">

**Author:** ![vijayakumar.balraj](https://avatars.discourse-cdn.com/v4/letter/v/e5b9ba/32.png) [@vijayakumar.balraj](https://discuss.elastic.co/u/vijayakumar.balraj)\
**Post date:** [September 20, 2018, 3:47am UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147/3 "2018-09-20T03:47:07Z")

</div>

I installed rpm using ansible and systemctl command to start elasticsearch

---

<div class="post-metadata">

**Author:** ![vijayakumar.balraj](https://avatars.discourse-cdn.com/v4/letter/v/e5b9ba/32.png) [@vijayakumar.balraj](https://discuss.elastic.co/u/vijayakumar.balraj)\
**Post date:** [September 21, 2018, 12:55am UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147/4 "2018-09-21T00:55:29Z")

</div>

@rjernst can you please help us on priority to resolve the issue since its completely blocking us to move forward?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 19, 2018, 12:55am UTC](https://discuss.elastic.co/t/upgrade-from-5-6-5-to-6-3-2-elasticsearch-fails-due-to-caused-by-java-lang-illegalstateexception-unexpected-distribution-flavor-your-distribution-is-broken/149147/5 "2018-10-19T00:55:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
