# Upgrade from 5.6.6 to 6.2.4, elastic failed to start

**URL:** https://discuss.elastic.co/t/upgrade-from-5-6-6-to-6-2-4-elastic-failed-to-start/128741
**Category:** Elasticsearch
**Created:** [April 19, 2018, 3:58pm UTC](https://discuss.elastic.co/t/upgrade-from-5-6-6-to-6-2-4-elastic-failed-to-start/128741 "2018-04-19T15:58:48Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![Ant](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ant/32/33267_2.png) [@Ant](https://discuss.elastic.co/u/Ant)
#### Post date: [April 20, 2018, 10:04am UTC](https://discuss.elastic.co/t/upgrade-from-5-6-6-to-6-2-4-elastic-failed-to-start/128741/2 "2018-04-20T10:04:45Z")

</div>

> [@Job for elasticsearch.service failed because the control process exited with error code](https://discuss.elastic.co/t/job-for-elasticsearch-service-failed-because-the-control-process-exited-with-error-code/109831/2):
>
> Upgrading from 5.6.1 to 6.0.0. I install and when trying to start elasticsearch, it fails. Any ideas why?

following guidance from this post although it's an ubuntu build and I'm running Centos the issues are the same. An engineer here says that `/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec` was removed from 6 so it will never work so I made the changes that there recommended against by the elastict team memeber in the origionally quoated post plus removed that line and my install started. I'm still having issues talking to it but I'm going to create a new thread for that as it's a fresh issue. For those who found this and then find the service starts but they keep getting connection refused, for me there was a elasticsearch.yml.rmpnew which I replaced my config file with, essentially it's just

```auto
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

```

which allowed me to interact on localhost, but I don't get responses when I try to add a host ip

---

_[View the full topic](https://discuss.elastic.co/t/upgrade-from-5-6-6-to-6-2-4-elastic-failed-to-start/128741)._
