# Upgrade from 6.8.12 oss to 7.9.2 basic

**URL:** https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028
**Category:** Elasticsearch
**Created:** [September 25, 2020, 8:47pm UTC](https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028 "2020-09-25T20:47:03Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![searchy](https://avatars.discourse-cdn.com/v4/letter/s/ecb155/32.png) [@searchy](https://discuss.elastic.co/u/searchy)
#### Post date: [September 25, 2020, 8:47pm UTC](https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028/1 "2020-09-25T20:47:04Z")

</div>

Greetings wonderful elasticsearch wizards!

I was wondering if there was any way to do a ROLLING UPGRADE from oss to basic? Specifically, we are looking to go from 6.8.12 oss to 7.9.2 elastic basic.

I do see in some posts, that there are api incompatibility issues mentioned, but I was wondering if there were work arounds... I did test it and was unsuccessful.

So far I tested (3 node clusters):

attempt 6.8.12 oss -\> rolling upgrade -\> 7.9.2 basic

- can't install 7.9.2 basic dpkg over 6.8.12 oss dpkg.
- attempt to purge/force-purge oss dpkg, fails
- manually remove dpkg files, install 7.9.2 basic, seems garbled. elasticsearch won't start [fail]

attempt 6.8.12 oos -\> wipe node - rolling upgrade -\>7.9.2 basic

- pulled 1 node, reimage, install 7.9.2 basic
- new 7.9.2 basic node joins 6.8.12 oss cluster fine
- ILM error messages in logs. (not sure if disabling index life management would help)
- cluster replicates shard ok to 7.9.2 basic node fine.
- search calls don't fail, but will return 0 results for the new node. so 1/3 of the cluster queries now return 0 results.
- fail

attempt 6.8.12 oss -\> REINDEX \_source -\> new 7.9.2 cluster

- of course, works great.

attempt 6.8.12 oss -\> rolling upgrade -\> 7.9.2 oss

- of course, works great.

so, is a full cluster restart really the only way to go from oss to basic? or is a rolling upgrade possible at all?

also, it's understandable that the elastic distro won't just install over the oss distro... but is there some special magic to purge .deb dpkgs?

Thanks!

---

<div class="post-metadata">

### Author: ![searchy](https://avatars.discourse-cdn.com/v4/letter/s/ecb155/32.png) [@searchy](https://discuss.elastic.co/u/searchy)
#### Post date: [September 25, 2020, 10:50pm UTC](https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028/2 "2020-09-25T22:50:17Z")

</div>

I think my problems removing the elasticsearch-oss dpkg may have to do with docker and the PID 1/systemd assumption.

---

<div class="post-metadata">

### Author: ![searchy](https://avatars.discourse-cdn.com/v4/letter/s/ecb155/32.png) [@searchy](https://discuss.elastic.co/u/searchy)
#### Post date: [October 20, 2020, 3:37pm UTC](https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028/3 "2020-10-20T15:37:33Z")

</div>

bump. anyone know if a rolling upgrade is possible from oss to basic?  
or new apis require a full cluster restart? thanks!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 17, 2020, 3:37pm UTC](https://discuss.elastic.co/t/upgrade-from-6-8-12-oss-to-7-9-2-basic/250028/4 "2020-11-17T15:37:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
