# Upgrade from version 7.17.3 to 8.1.3 can't get past xpack logging error in upgrade assistant

**URL:** <https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616>\
**Category:** Kibana\
**Created:** [May 12, 2022, 5:59pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616 "2022-05-12T17:59:52Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Moxey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moxey/32/121036_2.png) [@Moxey](https://discuss.elastic.co/u/Moxey)\
**Post date:** [May 12, 2022, 5:59pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/1 "2022-05-12T17:59:52Z")

</div>

Upgrade deployment  
Generally available versions  
8.1.3 selected

Error:  
Your changes cannot be applied  
Kibana - 'xpack.security.audit.appender.type' is not allowed

Upgrade is greyed out.

This is not a just a warning, we cannot go further. Do we need to set the logging in the yml file to False to get around this?

![image](https://us1.discourse-cdn.com/elastic/original/3X/5/5/55a78218a96cfe420b212fc3c12c2f0142f542a6.png)

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [May 12, 2022, 7:27pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/2 "2022-05-12T19:27:32Z")

</div>

Hello Robert,

From which version are you trying to upgrade to 8.1.3?

Thanks!  
Bhavya

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [May 12, 2022, 7:30pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/3 "2022-05-12T19:30:27Z")

</div>

Also do you see this set in your cloud Kibana settings? The setting is deprecated. So you will have to remove it.

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![Moxey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moxey/32/121036_2.png) [@Moxey](https://discuss.elastic.co/u/Moxey)\
**Post date:** [May 13, 2022, 12:08pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/4 "2022-05-13T12:08:43Z")

</div>

We are using the Elastic SaaS solution and we are upgrading from version 7.17.3

---

<div class="post-metadata">

**Author:** ![Moxey](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moxey/32/121036_2.png) [@Moxey](https://discuss.elastic.co/u/Moxey)\
**Post date:** [May 13, 2022, 12:10pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/5 "2022-05-13T12:10:49Z")

</div>

Will the new audit log default setting remove the deprecated xpack audit log setting when we migrate to version 8?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 10, 2022, 12:11pm UTC](https://discuss.elastic.co/t/upgrade-from-version-7-17-3-to-8-1-3-cant-get-past-xpack-logging-error-in-upgrade-assistant/304616/6 "2022-06-10T12:11:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
