# Upgrade to 7.2

**URL:** https://discuss.elastic.co/t/upgrade-to-7-2/187913
**Category:** Kibana
**Created:** [June 27, 2019, 7:39pm UTC](https://discuss.elastic.co/t/upgrade-to-7-2/187913 "2019-06-27T19:39:42Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mathurin68](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@mathurin68](https://discuss.elastic.co/u/mathurin68)
#### Post date: [June 27, 2019, 7:39pm UTC](https://discuss.elastic.co/t/upgrade-to-7-2/187913/1 "2019-06-27T19:39:42Z")

</div>

My upgrade of my elkstack 6.8 to 7.2 seems to have gone OK(cluster is green) except for the following kibana error -

```
money@elkstack:/etc/kibana$ sudo systemctl status kibana.service
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: enabled)
   Active: failed (Result: start-limit-hit) since Thu 2019-06-27 19:21:07 UTC; 5min ago
  Process: 114280 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
 Main PID: 114280 (code=exited, status=1/FAILURE)

Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Unit entered failed state.
Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Failed with result 'exit-code'.
Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Service hold-off time over, scheduling restart.
Jun 27 19:21:07 elkstack systemd[1]: Stopped Kibana.
Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Start request repeated too quickly.
Jun 27 19:21:07 elkstack systemd[1]: Failed to start Kibana.
Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Unit entered failed state.
Jun 27 19:21:07 elkstack systemd[1]: kibana.service: Failed with result 'start-limit-hit'.

```

I'm not sure what else try...

---

<div class="post-metadata">

### Author: ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)
#### Post date: [June 27, 2019, 7:54pm UTC](https://discuss.elastic.co/t/upgrade-to-7-2/187913/2 "2019-06-27T19:54:21Z")

</div>

is there something in your config?  
I upgraded to 7.2 on my test cluster and it worked without any problem.

---

<div class="post-metadata">

### Author: ![mathurin68](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@mathurin68](https://discuss.elastic.co/u/mathurin68)
#### Post date: [June 27, 2019, 11:11pm UTC](https://discuss.elastic.co/t/upgrade-to-7-2/187913/3 "2019-06-27T23:11:39Z")

</div>

Hah yeah I knew it was something stupid I was doing...  
In my kibana.yml I had  
elasticsearch.url:  
and when I upgraded from 6.6 to 6.8 the cluster still worked  
but when I upgraded all the way to 7.2  
I had to change it in kibana.yml to  
elasticsearch.hosts:

... and everything seems to be starting now.

Thank you!!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 25, 2019, 11:11pm UTC](https://discuss.elastic.co/t/upgrade-to-7-2/187913/4 "2019-07-25T23:11:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
