# Upgrade to 8.x from 7.x | Error in Kibana

**URL:** <https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [October 31, 2022, 2:38pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829 "2022-10-31T14:38:27Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)\
**Post date:** [October 31, 2022, 2:38pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/1 "2022-10-31T14:38:27Z")

</div>

We are running 7.2, successfully upgraded to 7.17.6, and want to move to the 8.X version. All went fine with the 7.17.6 upgrade. On Kibana I see some upgrade issues (critical) but not sure how to resolve this.

**First error**

> Configuring the "pod ID" field has been deprecated and will be removed in 8.0.0. This plugin is designed to work with ECS, and expects this field to have a value of `kubernetes.pod.uid`. It has a different value configured in Source Configuration: Default
> 
> ### How to fix
> 
> Adjust your indexing to identify Kubernetes pods using "kubernetes.pod.uid"

**Second error**

> Configuring the "host name" field has been deprecated and will be removed in 8.0.0. This plugin is designed to work with ECS, and expects this field to have a value of `host.name`. It has a different value configured in Source Configuration: Default
> 
> ### How to fix
> 
> Adjust your indexing to identify hosts using "host.name"

**Third error**

> Configuring the "container ID" field has been deprecated and will be removed in 8.0.0. This plugin is designed to work with ECS, and expects this field to have a value of `container.id`. It has a different value configured in Source Configuration: Dev
> 
> ### How to fix
> 
> Adjust your indexing to identify Docker containers using "container.id"

It's giving me `How t fix`, but its not showing me where to fix. any help will be much appriciated.

Thanks  
Senthil

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 11:47pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/2 "2022-10-31T23:47:29Z")

</div>

How are you feeding data to Elasticsearch for indexing?

---

<div class="post-metadata">

**Author:** ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)\
**Post date:** [November 1, 2022, 1:12am UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/3 "2022-11-01T01:12:43Z")

</div>

Filebeat --\> Logstash --\> Elasticsearch --\> kibana.

---

<div class="post-metadata">

**Author:** ![Ivan\_Martos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_martos/32/52690_2.png) [@Ivan\_Martos](https://discuss.elastic.co/u/Ivan_Martos)\
**Post date:** [November 10, 2022, 2:50pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/4 "2022-11-10T14:50:37Z")

</div>

How was this please resolved?  
I have same issue in my kibana elastic cloud. When I check Upgrade asistant under " Kibana deprecation issues" I can see message

> ## 
> 
> Source configuration field "pod ID" is deprecated.
> 
> Configuring the "pod ID" field has been deprecated and will be removed in 8.0.0. This plugin is designed to work with ECS, and expects this field to have a value of `kubernetes.pod.uid`. It has a different value configured in Source Configuration: Default
> 
> ### How to fix
> 
> Adjust your indexing to identify Kubernetes pods using "kubernetes.pod.uid"

I'm not sure where to fix this. Is this in kibana index patterns, or logstash has to be updated or filebeat?  
I havent found any field `kubernetes.pod.id` in my configuration

---

<div class="post-metadata">

**Author:** ![Senthil\_ak](https://avatars.discourse-cdn.com/v4/letter/s/eb9ed0/32.png) [@Senthil\_ak](https://discuss.elastic.co/u/Senthil_ak)\
**Post date:** [November 10, 2022, 3:11pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/5 "2022-11-10T15:11:15Z")

</div>

@Ivan_Martos - It's not resolved, I asked a question but still didn't get any reply from anybody 😔

---

<div class="post-metadata">

**Author:** ![Ivan\_Martos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_martos/32/52690_2.png) [@Ivan\_Martos](https://discuss.elastic.co/u/Ivan_Martos)\
**Post date:** [November 10, 2022, 3:21pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/6 "2022-11-10T15:21:02Z")

</div>

@warkolm any idea please?

---

<div class="post-metadata">

**Author:** ![jjayapragasam](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jjayapragasam/32/113428_2.png) [@jjayapragasam](https://discuss.elastic.co/u/jjayapragasam)\
**Post date:** [November 16, 2022, 3:47pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/7 "2022-11-16T15:47:05Z")

</div>

having the same issue as well, any idea anyone?

---

<div class="post-metadata">

**Author:** ![coderxin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/coderxin/32/114406_2.png) [@coderxin](https://discuss.elastic.co/u/coderxin)\
**Post date:** [December 8, 2022, 12:31pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/8 "2022-12-08T12:31:26Z")

</div>

Same thing as @Ivan_Martos has.  
@warkolm is there any progress around this issue?

---

<div class="post-metadata">

**Author:** ![mgevans](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mgevans/32/66790_2.png) [@mgevans](https://discuss.elastic.co/u/mgevans)\
**Post date:** [December 22, 2022, 5:06pm UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/9 "2022-12-22T17:06:29Z")

</div>

Hey folks - check out settings here  
in Kibana go into Observability \> Metrics Inventory \> Settings. There are bunch of fields with defaults that if changed show up as possible issues upon upgrade. I think this is because the inventory in 8.x won't have customizable fields so you have to set them back to defaults.

---

<div class="post-metadata">

**Author:** ![Ivan\_Martos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_martos/32/52690_2.png) [@Ivan\_Martos](https://discuss.elastic.co/u/Ivan_Martos)\
**Post date:** [January 3, 2023, 8:19am UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/10 "2023-01-03T08:19:26Z")

</div>

thank you very much - this solved my issue!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 31, 2023, 8:19am UTC](https://discuss.elastic.co/t/upgrade-to-8-x-from-7-x-error-in-kibana/317829/11 "2023-01-31T08:19:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
