# Upgraded first node from 7.17.5 to 8.4. Won't start, claiming there is a 6.4.5 index, but I can't find it

**URL:** <https://discuss.elastic.co/t/upgraded-first-node-from-7-17-5-to-8-4-wont-start-claiming-there-is-a-6-4-5-index-but-i-cant-find-it/317811>\
**Category:** Elasticsearch\
**Created:** [October 31, 2022, 10:47am UTC](https://discuss.elastic.co/t/upgraded-first-node-from-7-17-5-to-8-4-wont-start-claiming-there-is-a-6-4-5-index-but-i-cant-find-it/317811 "2022-10-31T10:47:20Z")\
**Posts on this page:** 1\
**Showing post:** 10

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [November 2, 2022, 8:23am UTC](https://discuss.elastic.co/t/upgraded-first-node-from-7-17-5-to-8-4-wont-start-claiming-there-is-a-6-4-5-index-but-i-cant-find-it/317811/10 "2022-11-02T08:23:20Z")

</div>

Just to confirm that @Emily_Nicholson is right here. This can happen if you delete the last 6.x index and then immediately shut down a node to start the upgrade, because index deletes are a little asynchronous so the node may not have received the message about the last bad index being deleted before it's shut down.

Temporarily reverting the node back to 7.x and allowing it to rejoin the cluster will refresh the stale metadata. Downgrades don't work in general but in this specific situation it's ok because the 8.x node won't have changed anything on disk by this point.

> [@Brett\_C](#):
>
> 100% agree that the Error message would be more useful if it listed the problematic indices.

Unfortunately the 8.x node doesn't really have a way to provide this information - the problem is that the bad indices are too old for an 8.x node to even read their metadata which would be required to name them. However I'm not sure it really would help to know those names - you can't do anything different with this information.

That said, I see room for improvement in the error message and opened this PR:

> <https://github.com/elastic/elasticsearch/pull/91243>
>
> We've had a few reports of failed upgrades caused by deleting the last ancient i…ndex just before stopping the first node, which may not have allowed enough time for the deletion to complete. Today the resulting error message doesn't say how to address this, which leaves users struggling mid-upgrade. This commit makes the error message more actionable.

---

_[View the full topic](https://discuss.elastic.co/t/upgraded-first-node-from-7-17-5-to-8-4-wont-start-claiming-there-is-a-6-4-5-index-but-i-cant-find-it/317811)._
