# Upgraded from ES2.3.5 to 2.4.0, seeing: Transport response handler not found of id

**URL:** https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742
**Category:** Elasticsearch
**Created:** [September 4, 2016, 4:07am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742 "2016-09-04T04:07:07Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![teebu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/teebu/32/10119_2.png) [@teebu](https://discuss.elastic.co/u/teebu)
#### Post date: [September 4, 2016, 4:07am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/1 "2016-09-04T04:07:08Z")

</div>

I just upgraded to ES2.4.0 and I'm noticing these errors every time ES starts. What does this mean?

```auto
2016-09-04 04:03:38,655][WARN][transport] [caste] Transport response handler not found of id [238]
[2016-09-04 04:03:38,764][WARN][transport] [caste] Transport response handler not found of id [241]
[2016-09-04 04:03:39,567][WARN][transport] [caste] Transport response handler not found of id [246]
[2016-09-04 04:03:39,815][WARN][transport] [caste] Transport response handler not found of id [248]
[2016-09-04 04:03:42,886][WARN][transport] [caste] Transport response handler not found of id [313]
[2016-09-04 04:03:44,960][WARN][transport] [caste] Transport response handler not found of id [346]
[2016-09-04 04:03:44,994][WARN][transport] [caste] Transport response handler not found of id [347]
[2016-09-04 04:03:45,881][WARN][transport] [caste] Transport response handler not found of id [359]
[2016-09-04 04:03:46,007][WARN][transport] [caste] Transport response handler not found of id [360]
[2016-09-04 04:03:49,791][WARN][transport] [caste] Transport response handler not found of id [388]

```

---

<div class="post-metadata">

### Author: ![tinle](https://avatars.discourse-cdn.com/v4/letter/t/c77e96/32.png) [@tinle](https://discuss.elastic.co/u/tinle)
#### Post date: [September 4, 2016, 4:37am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/2 "2016-09-04T04:37:34Z")

</div>

Make sure all nodes are same version, 2.4. Do you have beats feeding into your cluster? Have you upgraded logstash to 2.4?

Tin

---

<div class="post-metadata">

### Author: ![teebu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/teebu/32/10119_2.png) [@teebu](https://discuss.elastic.co/u/teebu)
#### Post date: [September 4, 2016, 4:50am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/3 "2016-09-04T04:50:24Z")

</div>

all nodes are upgraded from 2.3.5 to 2.4, no beats. LS 1.5 using http protocol. I never seen this message before.

---

<div class="post-metadata">

### Author: ![tinle](https://avatars.discourse-cdn.com/v4/letter/t/c77e96/32.png) [@tinle](https://discuss.elastic.co/u/tinle)
#### Post date: [September 4, 2016, 7:03pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/4 "2016-09-04T19:03:10Z")

</div>

The only time I've seen that error message is when there is a mismatch in version. Maybe upgrade your LS?

Tin

---

<div class="post-metadata">

### Author: ![teebu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/teebu/32/10119_2.png) [@teebu](https://discuss.elastic.co/u/teebu)
#### Post date: [September 6, 2016, 7:21pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/5 "2016-09-06T19:21:56Z")

</div>

Thanks, unfortunately I cant upgrade LS, the plugins that I use don't work well with latest LS. I restarted the ES cluster with LS off, and I was still seeing these messages.

---

<div class="post-metadata">

### Author: ![tinle](https://avatars.discourse-cdn.com/v4/letter/t/c77e96/32.png) [@tinle](https://discuss.elastic.co/u/tinle)
#### Post date: [September 7, 2016, 2:48am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/6 "2016-09-07T02:48:20Z")

</div>

Yes, look like it might be something else then... Maybe Elastic people can chime in.

Tin

---

<div class="post-metadata">

### Author: ![Ids\_van\_der\_Molen](https://avatars.discourse-cdn.com/v4/letter/i/cc9497/32.png) [@Ids\_van\_der\_Molen](https://discuss.elastic.co/u/Ids_van_der_Molen)
#### Post date: [September 9, 2016, 6:46am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/7 "2016-09-09T06:46:26Z")

</div>

Hi, I also noticed the same errors when using ES 2.4.0 and logstash 2.4.0.

---

<div class="post-metadata">

### Author: ![ironbeast](https://avatars.discourse-cdn.com/v4/letter/i/b5a626/32.png) [@ironbeast](https://discuss.elastic.co/u/ironbeast)
#### Post date: [September 14, 2016, 8:01am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/8 "2016-09-14T08:01:20Z")

</div>

Yep, me too... It's just spitting log lines one after the other filling the whole disk...  
And sometimes this comes up: (elasticsearch03dev-es-cluster-dev is another node)  
[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s]]]; nested: RemoteTransportException[[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s][p]]]; nested: EsRejectedExecutionException[rejected execution of org.elasticsearch.transport.TransportService$4@6807b591 on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@5e53305a[Running, pool size = 4, active threads = 4, queued tasks = 4138, completed tasks = 29660586]]];]];  
[0]: index [.marvel-es-1-2016.09.14], type [node\_stats], id [AVcnnsDhtV0Qddn6Zthd], message [RemoteTransportException[[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s]]]; nested: RemoteTransportException[[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s][p]]]; nested: EsRejectedExecutionException[rejected execution of org.elasticsearch.transport.TransportService$4@6807b591 on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@5e53305a[Running, pool size = 4, active threads = 4, queued tasks = 4138, completed tasks = 29660586]]];]]  
[0]: index [.marvel-es-1-2016.09.14], type [node\_stats], id [AVcnnum-tV0Qddn6ZudA], message [RemoteTransportException[[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s]]]; nested: RemoteTransportException[[elasticsearch03dev-es-cluster-dev][10.206.13.216:9300][indices:data/write/bulk[s][p]]]; nested: EsRejectedExecutionException[rejected execution of org.elasticsearch.transport.TransportService$4@6131d78d on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@5e53305a[Running, pool size = 4, active threads = 4, queued tasks = 4005, completed tasks = 29662634]]];]];

---

<div class="post-metadata">

### Author: ![saeppl](https://avatars.discourse-cdn.com/v4/letter/s/c6cbf5/32.png) [@saeppl](https://discuss.elastic.co/u/saeppl)
#### Post date: [September 22, 2016, 10:05am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/9 "2016-09-22T10:05:28Z")

</div>

Same problem hier. We are running 4 data-nodes - all on es 2.4.0. I just upgraded all logstah-loggers to 2.4.0 but am still getting those transport errors.  
It might be helpful to know that we are running 2 servers with 2 nodes each.

---

<div class="post-metadata">

### Author: ![Kim-Kruse-Hansen](https://avatars.discourse-cdn.com/v4/letter/k/f1d935/32.png) [@Kim-Kruse-Hansen](https://discuss.elastic.co/u/Kim-Kruse-Hansen)
#### Post date: [September 22, 2016, 2:36pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/10 "2016-09-22T14:36:42Z")

</div>

Same problem for me . 2 separate clusters each with 2 nodes , all at 2.4.0  
Happens frequently

---

<div class="post-metadata">

### Author: ![kobyb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kobyb/32/11936_2.png) [@kobyb](https://discuss.elastic.co/u/kobyb)
#### Post date: [September 22, 2016, 2:59pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/11 "2016-09-22T14:59:11Z")

</div>

+1 (after upgrading to 2.4)

---

<div class="post-metadata">

### Author: ![tinle](https://avatars.discourse-cdn.com/v4/letter/t/c77e96/32.png) [@tinle](https://discuss.elastic.co/u/tinle)
#### Post date: [September 22, 2016, 3:57pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/12 "2016-09-22T15:57:26Z")

</div>

I have 2.4.0 running on a test cluster of 3 nodes and have not had time to look at it recently. I just checked this morning, and although the number of these WARNings has gone down, I do see them in 2 of the data nodes. I no longer see them in my dedicated master node.

From the look of it, these warnings happen when the nodes are memory stressed and/or experiencing high CPU load. Look like Elastic added these warnings in 2.4.

Check your ES logs and see if you also see GC, high load and/or NodeDisconnectedException around same time frame.

---

<div class="post-metadata">

### Author: ![ruwilliams](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@ruwilliams](https://discuss.elastic.co/u/ruwilliams)
#### Post date: [September 22, 2016, 6:39pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/13 "2016-09-22T18:39:03Z")

</div>

I also see this message not only during times of heavy load, but when system is rather quiet. I am running on GCE cloud. I wonder if this relates to network interruptions perhaps. Would be nice to know what this means.

---

<div class="post-metadata">

### Author: ![milleka2](https://avatars.discourse-cdn.com/v4/letter/m/9d8465/32.png) [@milleka2](https://discuss.elastic.co/u/milleka2)
#### Post date: [September 23, 2016, 2:09am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/14 "2016-09-23T02:09:31Z")

</div>

I'm seeing the same problem, so hoping elastic will respond. (edit: I found a solution, which is in the bottom of my post)

All of my nodes are 2.4.0. I just upgraded them all from 2.1.1 with 2.4.0. In my case, I have a master and n data nodes that are all behaving fine; however, I have a couple client-only (non-data, non-master) nodes that are showing this error after the upgrade.

I tried increasing memory allocations on those boxes, but that had no effect. There is no running logstash or kibana. The cluster is closed off for the moment, so there are no clients. I wondered if it was a networking issue, but I can reach the master from the client nodes (curl to the ES API works). They're on the same subnet, and I disabled iptables on the clients just in case. Nothing has helped. I'll try updating my log level next.

I'll add that this is preventing the client nodes from connecting to the master, so they're pretty useless.

edit: I noticed in logs later that I was seeing the below: failed to send join request to master [{Poltergeist}{eBP\_rUJCTDimhgLUTiduxg}{192.168.1.4}{192.168.1.4:9300}{data=false, master=true}], reason [RemoteTransportException[[Poltergeist][192.168.1.4:9300][internal:discovery/zen/join]]; nested: ConnectTransportException[[Star-Lord][10.x.x.x:9300] connect\_timeout[30s]]; nested: NotSerializableExceptionWrapper[connect\_timeout\_exception: connection timed out: /10.x.x.x:9300];

In this case, I saw an IP on a separate interface was being used to connect to the master. I temporarily turned that interface off and I was able to start my client without issues. Afterward, I reenabled that interface. Is this going to be ok or will the problem recur now that I've enabled the iface? For the time being (first few minutes after restart), it's ok. I suspect there's a config somewhere I should be able to set to get around this, as I can't keep shutting down our interfaces. How can I inform ES 2.4.0 to only use one interface for talking to master (but a separate interface for serving client requests)?

edit2 (solution for me): the config I needed to set was network.publish\_host. What's strange is I didn't need to put this in my prior configs. I've always used the default network settings in prior ES versions.

---

<div class="post-metadata">

### Author: ![seth.yes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/seth.yes/32/11788_2.png) [@seth.yes](https://discuss.elastic.co/u/seth.yes)
#### Post date: [September 26, 2016, 5:25pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/15 "2016-09-26T17:25:09Z")

</div>

+1 for this issue

followed @milleka2's advice to set network.publish\_host on each ES node and I'm still receiving the error.

---

<div class="post-metadata">

### Author: ![tinle](https://avatars.discourse-cdn.com/v4/letter/t/c77e96/32.png) [@tinle](https://discuss.elastic.co/u/tinle)
#### Post date: [September 26, 2016, 6:04pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/16 "2016-09-26T18:04:02Z")

</div>

Someone reported seeing this warning when they changed their network MTU.

So this seem to be related to losing packets.

> <https://github.com/elastic/elasticsearch/issues/20657>

---

<div class="post-metadata">

### Author: ![seth.yes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/seth.yes/32/11788_2.png) [@seth.yes](https://discuss.elastic.co/u/seth.yes)
#### Post date: [September 27, 2016, 4:03pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/17 "2016-09-27T16:03:06Z")

</div>

\*\*

## EDIT: The fix mentioned below did not stop this error from occurring.

\*\*

I think that lost packets could cause this, however there have been no changes in MTU settings at my site.

My understanding (and someone please correct me if I'm wrong) is that these errors are regarding events being lost at the transport layer for whatever reason... which would typically be network issues.

I'm unsure of everyone else's setup, but what seems to have been causing this for me was a misconfiguration on the client node in my cluster. I have two master-eligible nodes, two data-only nodes and one [client node](https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-node.html) (no data, non-master, meant for load balancing etc..).

The problem appears to have been that I had in my elasticsearch.yml:  
`
node.max_local_storage_nodes: 1
<!code>`

which doesn't make sense for a node that's not allowed to perform local data storage. When the client node would enter the cluster, all devices would be updated of the client node properties, e.g.  
`
[2016-09-26 13:06:25,386][INFO][cluster.service] [hyd-mon-storage01] added {{load-balance-node}{Pp9lrLb2S-W9VDY4d_zsKg}{10.191.4.126}{10.191.4.126:9300}{max_local_storage_nodes=1, data=false, master=false},}, reason: zen-disco-receive(from master [{phys-node}{PFjAWYe9T_W_VsmKm-hcFQ}{10.191.5.129}{10.191.5.129:9300}{max_local_storage_nodes=1, master=true}])
<!code>`

So they'd see it has storage nodes, the master would attempt to write to this device but it doesn't accept data, thus the event gets lost. Furthermore, I was seeing my primary index randomly get deleted and changing:

`node.max_local_storage_nodes: 0<!code>`

appears to have resolved this issue for me.

If you're still seeing this error in your cluster, I'd attempt to recreate the path an event takes from logstash into your cluster, all the way through to a data node.. there's likely some misconfig causing the errors. I'll keep updating this thread with any further results and conclusions I reach.

---

<div class="post-metadata">

### Author: ![Andrew\_Stoker](https://avatars.discourse-cdn.com/v4/letter/a/8797f3/32.png) [@Andrew\_Stoker](https://discuss.elastic.co/u/Andrew_Stoker)
#### Post date: [September 27, 2016, 6:34pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/18 "2016-09-27T18:34:18Z")

</div>

I have the same issue. Quick search of upcoming 2.4.1 release may have the fix [https://github.com/elastic/elasticsearch/pull/20585](https://github.com/elastic/elasticsearch/pull/20585)

---

<div class="post-metadata">

### Author: ![Andrew\_Stoker](https://avatars.discourse-cdn.com/v4/letter/a/8797f3/32.png) [@Andrew\_Stoker](https://discuss.elastic.co/u/Andrew_Stoker)
#### Post date: [September 29, 2016, 10:15am UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/19 "2016-09-29T10:15:07Z")

</div>

I can confirm that with the 2.4.1 release this error has been resolved.

---

<div class="post-metadata">

### Author: ![seth.yes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/seth.yes/32/11788_2.png) [@seth.yes](https://discuss.elastic.co/u/seth.yes)
#### Post date: [September 29, 2016, 3:55pm UTC](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742/20 "2016-09-29T15:55:37Z")

</div>

Also confirmed that upgrading to 2.4.1 resolves this issue.

[Next page](https://discuss.elastic.co/t/upgraded-from-es2-3-5-to-2-4-0-seeing-transport-response-handler-not-found-of-id/59742.md?page=2)
