# Upgrading from 5.6.12.to 5.6.13 on Fedora 27 - elastic service fails on startup

**URL:** <https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651>\
**Category:** Elasticsearch\
**Created:** [November 14, 2018, 12:03pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651 "2018-11-14T12:03:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Capitals](https://avatars.discourse-cdn.com/v4/letter/c/51bf81/32.png) [@Capitals](https://discuss.elastic.co/u/Capitals)\
**Post date:** [November 14, 2018, 12:03pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651/1 "2018-11-14T12:03:53Z")

</div>

I have a Fedora 27 server with Elasticsearch 5.6.12, Logstash 5.6.12 and Java JDK 1.8.0-181. Working just fine...

I just upgraded, in 2 seperate VM's, from ElasticSearch 5.6.12. to 5.6.13

VM 1. upgrading with RPM from website (only ElasticSearch 5.6.13)

VM 2. upgrading through Fedora software updates (includes to ElasticSearch 5.6.13, Java JDK 1.8.0-191 and Logstash 5.6.13)

After the upgrade, and after a reboot, the elastic service fails with the same error in both senarios:

/usr/share/elasticsearch/lib/plugin-cli-5.6.13.tar requieres elasticsearch 5.6.13, your system: 5.6.12.

Before sending tons of logs can anyone help me with what this means? Thank you..

---

<div class="post-metadata">

**Author:** ![byronvoorbach](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/byronvoorbach/32/8283_2.png) [@byronvoorbach](https://discuss.elastic.co/u/byronvoorbach)\
**Post date:** [November 14, 2018, 3:11pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651/2 "2018-11-14T15:11:27Z")

</div>

Plugins are built for a specific version. When you upgrade your ES, you'll have to remove all your plugins and reinstall them with the correct version.

It seems from the last line that you're trying to install 5.6.13 plugin onto a 5.6.12 ES, meaning that the upgrade did not succeed. Can you confirm the new version on the machine? It feels like that message should be the other way around though, that you still have 5.6.12 plugin when trying to run 5.6.13

---

<div class="post-metadata">

**Author:** ![Capitals](https://avatars.discourse-cdn.com/v4/letter/c/51bf81/32.png) [@Capitals](https://discuss.elastic.co/u/Capitals)\
**Post date:** [November 14, 2018, 3:54pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651/3 "2018-11-14T15:54:02Z")

</div>

I stopped ES service, renamed /usr/share/elasticsearch to \_old, downloaded ES 5.6.13 RPM from [elastic.co](http://elastic.co) and updated through software updater, rebooted, checked [http://elastic.server:9200](http://elastic.server:9200) for version 5.6.13 = succes. Ran all updates fro software updates, rebooted and it worked. Thanks for helping.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2018, 3:54pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-12-to-5-6-13-on-fedora-27-elastic-service-fails-on-startup/156651/4 "2018-12-12T15:54:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
