# Upgrading from 5.6.8 to 6.8

**URL:** https://discuss.elastic.co/t/upgrading-from-5-6-8-to-6-8/209177
**Category:** Elasticsearch
**Created:** [November 24, 2019, 12:14pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-8-to-6-8/209177 "2019-11-24T12:14:07Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Callonski](https://avatars.discourse-cdn.com/v4/letter/c/46a35a/32.png) [@Callonski](https://discuss.elastic.co/u/Callonski)
#### Post date: [November 24, 2019, 12:14pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-8-to-6-8/209177/1 "2019-11-24T12:14:07Z")

</div>

Hi, I'm having some trouble upgrading elasticsearch.  
Following : [https://www.elastic.co/guide/en/elasticsearch/reference/6.8/rolling-upgrades.html](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/rolling-upgrades.html)  
And: [https://www.elastic.co/guide/en/elasticsearch/reference/6.8/deb.html](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/deb.html)

But I get :  
warning: Falling back to java on path. This behavior is deprecated. Specify JAVA\_HOME  
ERROR: keystore does not exist at [/etc/default/elasticsearch.keystore]  
dpkg: error processing package elasticsearch (--configure):  
subprocess installed post-installation script returned error exit status 78  
Errors were encountered while processing:  
elasticsearch  
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried setting JAVA\_HOME in: etc/default/elasticsearch as:  
JAVA\_HOME=/usr/lib/jvm/java-1.8.0-openjdk-amd64

But not quite sure how to get it right... Anyone got a clue?

Thanks!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 22, 2019, 12:14pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-8-to-6-8/209177/2 "2019-12-22T12:14:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
