# Upgrading from 5.6 to 6.x

**URL:** https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541
**Category:** Elasticsearch
**Created:** [June 27, 2018, 6:00am UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541 "2018-06-27T06:00:50Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![anush\_jayan](https://avatars.discourse-cdn.com/v4/letter/a/278dde/32.png) [@anush\_jayan](https://discuss.elastic.co/u/anush_jayan)
#### Post date: [June 27, 2018, 6:00am UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541/1 "2018-06-27T06:00:50Z")

</div>

when im trying to upgrade from 5.6 to 6.x im getting some errors im trying to do a rolling upgrade  
below i have given the error which im getting even though i havent installed any plugins

[2018-06-27T05:48:38,655][INFO][o.e.p.PluginsService] [es01\_node] loaded module [transport-netty4]  
[2018-06-27T05:48:38,655][INFO][o.e.p.PluginsService] [es01\_node] loaded module [tribe]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-core]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-deprecation]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-graph]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-logstash]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-ml]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-monitoring]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-rollup]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-security]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-sql]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-upgrade]  
[2018-06-27T05:48:38,656][INFO][o.e.p.PluginsService] [es01\_node] loaded module [x-pack-watcher]  
[2018-06-27T05:48:38,657][INFO][o.e.p.PluginsService] [es01\_node] no plugins loaded  
[2018-06-27T05:48:42,118][ERROR][o.e.b.Bootstrap] Exception  
java.lang.IllegalArgumentException: unknown setting [path.conf] please check that any required plugins are installed, or check the breaking changes documentation for removed settings  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:344) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:308) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:282) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:135) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.node.Node.(Node.java:339) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) [elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) [elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) [elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) [elasticsearch-6.3.0.jar:6.3.0]  
[2018-06-27T05:48:42,125][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [es01\_node] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [path.conf] please check that any required plugins are installed, or check the breaking changes documentation for removed settings  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.3.0.jar:6.3.0]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.3.0.jar:6.3.0]  
Caused by: java.lang.IllegalArgumentException: unknown setting [path.conf] please check that any required plugins are installed, or check the breaking changes documentation for removed settings  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:344) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:308) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:282) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:135) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.node.Node.(Node.java:339) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:326) ~[elasticsearch-6.3.0.jar:6.3.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.3.0.jar:6.3.0]

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 27, 2018, 6:12am UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541/2 "2018-06-27T06:12:00Z")

</div>

> [@anush\_jayan](#):
>
> path.conf

Please see [https://www.elastic.co/guide/en/elasticsearch/reference/6.3/breaking\_60\_packaging\_changes.html#\_literal\_path\_conf\_literal\_is\_no\_longer\_a\_configurable\_setting](https://www.elastic.co/guide/en/elasticsearch/reference/6.3/breaking_60_packaging_changes.html#_literal_path_conf_literal_is_no_longer_a_configurable_setting)

---

<div class="post-metadata">

### Author: ![anush\_jayan](https://avatars.discourse-cdn.com/v4/letter/a/278dde/32.png) [@anush\_jayan](https://discuss.elastic.co/u/anush_jayan)
#### Post date: [July 6, 2018, 7:10am UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541/3 "2018-07-06T07:10:52Z")

</div>

ailed\_allocation\_attempts" : 5,  
"details" : "failed recovery, failure RecoveryFailedException[[prirequestlog-2018.05.22][1]: Recovery failed from {es01\_node}{rq7WtIWjRBGSaYPjz54t5A}{mXEEmLcSQYupBlkCr\_ou3w}{xx.xx.xx.xxx}{xx.xx.xx.xx:9300}{ml.machine\_memory=4145360896, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true} into {es02\_node}{Pt3tgCviQke3HLksk-xY0w}{lSLI\_axFRXC7NF6SO6lt6w}{xxx.xxx.xx.xxx}{xx.xxx.xx.xx:9300}{ml.machine\_memory=4145360896, xpack.installed=true, ml.max\_open\_jobs=20, ml.enabled=true}]; nested: RemoteTransportException[[es01\_node][xx.xxxx.xx.xx:9300][internal:index/shard/recovery/start\_recovery]]; nested: RecoveryEngineException[Phase[1] prepare target for translog failed]; nested: RemoteTransportException[[es02\_node][xx.xx.xx.xx:9300][internal:index/shard/recovery/prepare\_translog]]; nested: IllegalStateException[commit doesn't contain history uuid]; ",

"decision" : "NO",  
"explanation" : "shard has exceeded the maximum number of retries [5] on failed allocation attempts - manually call [/\_cluster/reroute?retry\_failed=true] to retry, [unassigned\_info[[reason=ALLOCATION\_FAILED], at[2018-06-28T08:07:34.551Z], failed\_attempts[5], delayed=false, details[failed recovery, failure RecoveryFailedException[[prirequestlog-2018.05.22][1]: Recovery failed from {es01\_node}{rq7WtIWjRBGSaYPjz54t5A}{mXEEmLcSQYupBlkCr\_ou3w}{xx.xx.xx.xx}{xx.xx.xx.xx:9300}{ml.machine\_memory=4145360896, ml.max\_open\_jobs=20, xpack.installed=true, ml.enabled=true} into {es02\_node}{Pt3tgCviQke3HLksk-xY0w}{lSLI\_axFRXC7NF6SO6lt6w}{xx.xx.xx.xx}{xx.xx.xx.xx:9300}{ml.machine\_memory=4145360896, xpack.installed=true, ml.max\_open\_jobs=20, ml.enabled=true}]; nested: RemoteTransportException[[es01\_node][xx.xx.xx.xx:9300][internal:index/shard/recovery/start\_recovery]]; nested: RecoveryEngineException[Phase[1] prepare target for translog failed]; nested: RemoteTransportException[[es02\_node][xx.xx.xx.xx:9300][internal:index/shard/recovery/prepare\_translog]]; nested: IllegalStateException[commit doesn't contain history uuid]; ], allocation\_status[no\_attempt]]

im getting this error when i run this curl -XGET localhost:9200/\_cluster/allocation/explain?pretty

---

<div class="post-metadata">

### Author: ![nhat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nhat/32/22170_2.png) [@nhat](https://discuss.elastic.co/u/nhat)
#### Post date: [July 7, 2018, 10:42pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541/4 "2018-07-07T22:42:07Z")

</div>

This is a known issue [https://github.com/elastic/elasticsearch/issues/31482](https://github.com/elastic/elasticsearch/issues/31482). It was fixed and released in v6.3.1. Can you please upgrade to the latest version, then issue `POST /_cluster/reroute?retry_failed=true`?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 4, 2018, 10:42pm UTC](https://discuss.elastic.co/t/upgrading-from-5-6-to-6-x/137541/5 "2018-08-04T22:42:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
