# Upgrading Kibana 7.17.15 -\> 7.17.18 FATAL ERROR

**URL:** <https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299>\
**Category:** Kibana\
**Created:** [February 14, 2024, 4:32pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299 "2024-02-14T16:32:41Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![jasonperrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonperrone/32/128615_2.png) [@jasonperrone](https://discuss.elastic.co/u/jasonperrone)\
**Post date:** [February 14, 2024, 4:32pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/1 "2024-02-14T16:32:41Z")

</div>

I upgraded my Kibana from 7.17.15 -\> 7.17.18. On startup received: FATAL Error: EACCES: permission denied, stat '/nonexistent/.config/puppeteer'.

Downgraded back to 7.17.15 =\> Problem disappeared.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [February 14, 2024, 5:22pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/2 "2024-02-14T17:22:36Z")

</div>

Hi @jasonperrone,

Welcome back! Do you see any errors or warnings in the logs?

---

<div class="post-metadata">

**Author:** ![jasonperrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonperrone/32/128615_2.png) [@jasonperrone](https://discuss.elastic.co/u/jasonperrone)\
**Post date:** [February 14, 2024, 5:46pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/3 "2024-02-14T17:46:08Z")

</div>

Hello! Just this, that I've seen since 7.17.13: Kibana is currently running with legacy OpenSSL providers enabled! For details and instructions on how to disable see [Use Kibana in a production environment | Kibana Guide [7.17] | Elastic](https://www.elastic.co/guide/en/kibana/7.17/production.html#openssl-legacy-provider)

---

<div class="post-metadata">

**Author:** ![tonybfj](https://avatars.discourse-cdn.com/v4/letter/t/ccd318/32.png) [@tonybfj](https://discuss.elastic.co/u/tonybfj)\
**Post date:** [February 29, 2024, 7:22am UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/4 "2024-02-29T07:22:03Z")

</div>

@jasonperrone Hi Jason , how did you go about resolving this issue ?

Cheers

---

<div class="post-metadata">

**Author:** ![jasonperrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonperrone/32/128615_2.png) [@jasonperrone](https://discuss.elastic.co/u/jasonperrone)\
**Post date:** [February 29, 2024, 12:29pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/5 "2024-02-29T12:29:35Z")

</div>

I haven't resolved it. I am currently still stuck on 7.17.15 because I'm not getting any help from Elastic or the community.

---

<div class="post-metadata">

**Author:** ![tonybfj](https://avatars.discourse-cdn.com/v4/letter/t/ccd318/32.png) [@tonybfj](https://discuss.elastic.co/u/tonybfj)\
**Post date:** [February 29, 2024, 1:23pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/6 "2024-02-29T13:23:52Z")

</div>

Hi @jasonperrone sorry to hear that , i thought as per the solution status you had resolved the issue.

What have support had to say thus far ?

---

<div class="post-metadata">

**Author:** ![jasonperrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonperrone/32/128615_2.png) [@jasonperrone](https://discuss.elastic.co/u/jasonperrone)\
**Post date:** [February 29, 2024, 1:25pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/7 "2024-02-29T13:25:57Z")

</div>

Oh I see, I don't know why it says solved, I merely responded and it got marked as "Solution". I wonder if I can undo that. Are you having the same problem?

---

<div class="post-metadata">

**Author:** ![ahmed\_charafouddine](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ahmed_charafouddine/32/45129_2.png) [@ahmed\_charafouddine](https://discuss.elastic.co/u/ahmed_charafouddine)\
**Post date:** [February 29, 2024, 1:27pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/8 "2024-02-29T13:27:24Z")

</div>

Hello @jasonperrone  
Can you test this by changing the rights of the /nonexistent/.config/puppeteer file for example.

---

<div class="post-metadata">

**Author:** ![jasonperrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasonperrone/32/128615_2.png) [@jasonperrone](https://discuss.elastic.co/u/jasonperrone)\
**Post date:** [February 29, 2024, 1:47pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/9 "2024-02-29T13:47:02Z")

</div>

So, first of all, there is no .config in /nonexistent. The permissions on /nonexistent are 600, owned by elasticsearch:elasticsearch. I change the permissions to 660 and added kibana to the elasticsearch group. Did not help. I changed the permissions /nonexistent to 666, still did not help. Changed the permissions on /nonexistent to 777 and that worked. But I don't know if my IT department is going to cite me for having totally open permissions on that directory. I wish I knew why I even have this directory. I have a second Elastic cluster with Kibana, and there is no such directory on those servers.

---

<div class="post-metadata">

**Author:** ![valtera2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/valtera2/32/132361_2.png) [@valtera2](https://discuss.elastic.co/u/valtera2)\
**Post date:** [March 5, 2024, 4:16pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/10 "2024-03-05T16:16:48Z")

</div>

I did experience the same error after upgrading to 7.17.18 while also having /nonexistent on filesystem, owned by elasticsearch as well.  
What did help me was removing that directory completely. Afterwards, Kibana started with no problems.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 2, 2024, 4:17pm UTC](https://discuss.elastic.co/t/upgrading-kibana-7-17-15-7-17-18-fatal-error/353299/11 "2024-04-02T16:17:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
