# Upgrading Kibana from 7.14.2 to 7.15.X results in error TypeError: Cannot read property 'schema' of undefined

**URL:** <https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417>\
**Category:** Kibana\
**Created:** [November 4, 2021, 2:19pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417 "2021-11-04T14:19:58Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![kking-biometrica](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kking-biometrica/32/96723_2.png) [@kking-biometrica](https://discuss.elastic.co/u/kking-biometrica)\
**Post date:** [November 4, 2021, 2:19pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/1 "2021-11-04T14:19:58Z")

</div>

I'm trying to upgrade Kibana on a Linux platform.

When upgrading, I am performing the following actions:

1. Download and extract linux `tar.gz` file to a temp location
2. Stop Kibana
3. Backup existing Kibana install: `sudo cp -Rp kibana kibana_backup`
4. Overwrite Kibana install with the files in the temp location
5. Restore configuration files into updated Kibana install
6. Confirm file and folder permissions are correct (`kibana` user owns `logs`,`pid folder`)
7. Start Kibana

The result is that Kibana does not start. If I attempt to run Kibana in the foreground, I get:

```auto
$ sudo bin/kibana --verbose --allow-root
 FATAL TypeError: Cannot read property 'schema' of undefined

```

I have tried this on both the integration instance and an brand new test instance.

Version info after upgrade:

```auto
$ sudo bin/kibana --version --allow-root
7.15.1
$ sudo bin/elasticsearch --version
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Version: 7.15.1, Build: default/tar/83c34f456ae29d60e94d886e455e6a3409bba9ed/2021-10-07T21:56:19.031608185Z, JVM: 11.0.12

```

Kibana Configuration

```auto
path:
  data: /data/kibana/data
logging:
  dest: /opt/kibana/logs/kibana.log
pid:
  file: /opt/kibana/tmp/kibana.pid
server:
  host: 0.0.0.0
  port: "5601"
elasticsearch:
  hosts: http://127.0.0.1:9200
  password: xxxxxxxx
  username: xxxxxxxx

```

---

<div class="post-metadata">

**Author:** ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)\
**Post date:** [November 4, 2021, 2:25pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/2 "2021-11-04T14:25:06Z")

</div>

> [@kking-biometrica](#):
>
> ` FATAL TypeError: Cannot read property 'schema' of undefined`

Mind attaching the error message with the error stack and kibana logs as well, please?

---

<div class="post-metadata">

**Author:** ![kking-biometrica](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kking-biometrica/32/96723_2.png) [@kking-biometrica](https://discuss.elastic.co/u/kking-biometrica)\
**Post date:** [November 4, 2021, 2:46pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/3 "2021-11-04T14:46:04Z")

</div>

I don't see anything in `kibana.log` - where would I find the "error stack"?

relevant log bits: [https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing](https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing)

---

<div class="post-metadata">

**Author:** ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)\
**Post date:** [November 4, 2021, 3:21pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/4 "2021-11-04T15:21:58Z")

</div>

> [@kking-biometrica](#):
>
> I don't see anything in `kibana.log` - where would I find the "error stack"?

I guess, in the same place when you found `FATAL TypeError: Cannot read property 'schema' of undefined` error message.

> relevant log bits: [https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing](https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing)

I can't find `TypeError: Cannot read property 'schema' of undefined` error message in the file. Are you sure it's the full file?

---

<div class="post-metadata">

**Author:** ![kking-biometrica](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kking-biometrica/32/96723_2.png) [@kking-biometrica](https://discuss.elastic.co/u/kking-biometrica)\
**Post date:** [November 4, 2021, 3:37pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/5 "2021-11-04T15:37:51Z")

</div>

It's not the full file; however, you are correct that the message does not appear in the log - it only appears on the console when I run kibana in the foreground.

The log is the associated log data from the time when I ran the command. Otherwise, the message is not logged.

---

<div class="post-metadata">

**Author:** ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)\
**Post date:** [November 4, 2021, 3:42pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/6 "2021-11-04T15:42:31Z")

</div>

> [@kking-biometrica](#):
>
> The log is the associated log data from the time when I ran the command. Otherwise, the message is not logged.

Do you mean that Kibana crashes silently or does it function normally?  
Right now it sounds like a potential bug. Would you mind creating a bug report and providing steps to reproduce the problem? [Sign in to GitHub · GitHub](https://github.com/elastic/kibana/issues/new?assignees=&labels=bug&template=Bug_report.md)

---

<div class="post-metadata">

**Author:** ![kking-biometrica](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kking-biometrica/32/96723_2.png) [@kking-biometrica](https://discuss.elastic.co/u/kking-biometrica)\
**Post date:** [November 4, 2021, 4:12pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/7 "2021-11-04T16:12:57Z")

</div>

It crashes silently from my POV when I try and `systemctl start kibana` - `journalctl` indicates it starts successfully and then it must either hang or stop but `systemctl` doesn't indicate running if I check it's status. In that case (running as service), nothing at all is even logged in `kibana.log`.

Note: everything works just fine if I perform a rollback

If I run in the foreground it gives me the `cannot read property` error.

Bug Report: [https://github.com/elastic/kibana/issues/117556](https://github.com/elastic/kibana/issues/117556)

---

<div class="post-metadata">

**Author:** ![kking-biometrica](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kking-biometrica/32/96723_2.png) [@kking-biometrica](https://discuss.elastic.co/u/kking-biometrica)\
**Post date:** [November 5, 2021, 1:38pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/8 "2021-11-05T13:38:46Z")

</div>

Issue is solved. It appears files from the old install may have been causing the issue. Moving the old install, copying back the appropriate folders, and setting the permissions corrected the issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 3, 2021, 1:39pm UTC](https://discuss.elastic.co/t/upgrading-kibana-from-7-14-2-to-7-15-x-results-in-error-typeerror-cannot-read-property-schema-of-undefined/288417/9 "2021-12-03T13:39:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
