# Upgrading kibana from 8.18.4 to 8.19.4

**URL:** <https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668>\
**Category:** Elasticsearch\
**Created:** [January 21, 2026, 10:24am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668 "2026-01-21T10:24:10Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anjali3](https://avatars.discourse-cdn.com/v4/letter/a/48db29/32.png) [@Anjali3](https://discuss.elastic.co/u/Anjali3)\
**Post date:** [January 21, 2026, 10:24am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668/1 "2026-01-21T10:24:10Z")

</div>

Hi Team,

Need quick help! I am upgrading elasticsearch from 8.18.4 to 8.19.4 but getting below errors:

at org.elasticsearch.server.cli.JvmOption.flagsFinal(JvmOption.java:125) at org.elasticsearch.server.cli.JvmOption.findFinalOptions(JvmOption.java:90) at org.elasticsearch.server.cli.MachineDependentHeap.determineHeapSettings(MachineDependentHeap.java:59) at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:146) at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:98) at org.elasticsearch.server.cli.ServerCli.startServer(ServerCli.java:269) at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:112) at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:55) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:101) at org.elasticsearch.cli.Command.main(Command.java:54) at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:65) java.lang.RuntimeException: starting java failed with [1] output: [0.000s][error][logging] Error opening log file 'logs/gc.log': No such file or directory [0.000s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed. error: Invalid -Xlog option '-Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,level,pid,tags:filecount=32,filesize=64m', see error log for details. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. at org.elasticsearch.server.cli.JvmOption.flagsFinal(JvmOption.java:125) at org.elasticsearch.server.cli.JvmOption.findFinalOptions(JvmOption.java:90) at org.elasticsearch.server.cli.MachineDependentHeap.determineHeapSettings(MachineDependentHeap.java:59) at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:146) at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:98) at org.elasticsearch.server.cli.ServerCli.startServer(ServerCli.java:269) at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:112) at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:55) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:101) at org.elasticsearch.cli.Command.main(Command.java:54) at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:65) java.lang.RuntimeException: starting java failed with [1] output: [0.000s][error][logging] Error opening log file 'logs/gc.log': No such file or directory [0.000s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed. error: Invalid -Xlog option '-Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,level,pid,tags:filecount=32,filesize=64m', see error log for details. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. at org.elasticsearch.server.cli.JvmOption.flagsFinal(JvmOption.java:125) at org.elasticsearch.server.cli.JvmOption.findFinalOptions(JvmOption.java:90) at org.elasticsearch.server.cli.MachineDependentHeap.determineHeapSettings(MachineDependentHeap.java:59) at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:146) at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:98) at org.elasticsearch.server.cli.ServerCli.startServer(ServerCli.java:269) at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:112) at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:55) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:101) at org.elasticsearch.cli.Command.main(Command.java:54) at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:65) java.lang.RuntimeException: starting java failed with [1] output: [0.001s][error][logging] Error opening log file 'logs/gc.log': No such file or directory [0.001s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed. error: Invalid -Xlog option '-Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,level,pid,tags:filecount=32,filesize=64m', see error log for details. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. at org.elasticsearch.server.cli.JvmOption.flagsFinal(JvmOption.java:125) at org.elasticsearch.server.cli.JvmOption.findFinalOptions(JvmOption.java:90) at org.elasticsearch.server.cli.MachineDependentHeap.determineHeapSettings(MachineDependentHeap.java:59) at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:146) at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:98) at org.elasticsearch.server.cli.ServerCli.startServer(ServerCli.java:269) at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:112) at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:55) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:101) at org.elasticsearch.cli.Command.main(Command.java:54) at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:65) java.lang.RuntimeException: starting java failed with [1] output: [0.000s][error][logging] Error opening log file 'logs/gc.log': No such file or directory [0.000s][error][logging] Initialization of output 'file=logs/gc.log' using options 'filecount=32,filesize=64m' failed. error: Invalid -Xlog option '-Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,level,pid,tags:filecount=32,filesize=64m', see error log for details. Error: Could not create the Java Virtual Machine. Error: A fatal exception has occurred. Program will exit. at org.elasticsearch.server.cli.JvmOption.flagsFinal(JvmOption.java:125) at org.elasticsearch.server.cli.JvmOption.findFinalOptions(JvmOption.java:90) at org.elasticsearch.server.cli.MachineDependentHeap.determineHeapSettings(MachineDependentHeap.java:59) at org.elasticsearch.server.cli.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:146) at org.elasticsearch.server.cli.JvmOptionsParser.determineJvmOptions(JvmOptionsParser.java:98) at org.elasticsearch.server.cli.ServerCli.startServer(ServerCli.java:269) at org.elasticsearch.server.cli.ServerCli.execute(ServerCli.java:112) at org.elasticsearch.common.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:55) at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:101) at org.elasticsearch.cli.Command.main(Command.java:54) at org.elasticsearch.launcher.CliToolLauncher.main(CliToolLauncher.java:65) [root@NJDMTSVPELKC1A4 elasticsearch]#

---

<div class="post-metadata">

**Author:** ![Anjali3](https://avatars.discourse-cdn.com/v4/letter/a/48db29/32.png) [@Anjali3](https://discuss.elastic.co/u/Anjali3)\
**Post date:** [January 21, 2026, 10:37am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668/2 "2026-01-21T10:37:49Z")

</div>

Anybody?

---

<div class="post-metadata">

**Author:** ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Post date:** [January 21, 2026, 11:17am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668/3 "2026-01-21T11:17:28Z")

</div>

Hello @Anjali3

Looking at the error message maybe you can check the jvm.options file & see if there is any issue with the parameters causing this problem?

Similar post with same error reported issue with jvm.options file :

> [@Error while installing offline Elasticsearch 7.12](https://discuss.elastic.co/t/error-while-installing-offline-elasticsearch-7-12/276659):
>
> Hi everyone. I'm trying to install Elasticsearch 7.12.1 on a server for a customer. The OS is Ubuntu Server 9.3.0-17 aka 20.04 (the LTS one). OpenJDK 16 included. This server is offline so I downloaded the deb package : elasticsearch-7.12.1-amd64.deb I installed it accoding to the following documentation : [Install Elasticsearch with Debian Package | Elasticsearch Guide [7.12] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.12/deb.html#install-deb) I then copied my version of elasticsearch.yml to /etc/elastic/ folder. Everything works fine until reach…

Thanks!!

---

<div class="post-metadata">

**Author:** ![Anjali3](https://avatars.discourse-cdn.com/v4/letter/a/48db29/32.png) [@Anjali3](https://discuss.elastic.co/u/Anjali3)\
**Post date:** [January 21, 2026, 11:27am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668/4 "2026-01-21T11:27:46Z")

</div>

can you exactly tell me what do i need to check…it is 3 node elk cluster on docker

---

<div class="post-metadata">

**Author:** ![anteNOORR](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/antenoorr/32/146749_2.png) [@anteNOORR](https://discuss.elastic.co/u/anteNOORR)\
**Post date:** [January 28, 2026, 10:50am UTC](https://discuss.elastic.co/t/upgrading-kibana-from-8-18-4-to-8-19-4/384668/5 "2026-01-28T10:50:01Z")

</div>

Looking at error message it seems this is related to the absolute path for JVM logging requirement in jvm.options file, I had a similar issue and resolved to me. Give it a try.

## GC logging

-Xlog:gc\*,gc+age=trace,safepoint:_ **file=logs/gc.log** _:utctime,level,pid,tags:filecount=32,filesize=64m
