# Upgrading License X-Pack Failed

**URL:** <https://discuss.elastic.co/t/upgrading-license-x-pack-failed/70894>\
**Category:** Elasticsearch\
**Created:** [January 8, 2017, 7:18pm UTC](https://discuss.elastic.co/t/upgrading-license-x-pack-failed/70894 "2017-01-08T19:18:19Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![gutasaputra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gutasaputra/32/10472_2.png) [@gutasaputra](https://discuss.elastic.co/u/gutasaputra)\
**Post date:** [January 8, 2017, 7:18pm UTC](https://discuss.elastic.co/t/upgrading-license-x-pack-failed/70894/1 "2017-01-08T19:18:19Z")

</div>

i got this message :

> Your Trial license is active

i try to upgrade it.  
i know im not yet a subscription user of xpack.

so i try to upgrade the license using basic license.  
i got the license.json

i run this command :  
`curl -XPUT -u elastic 'http://localhost:9200/_xpack/license' -d @license_xpack.json`

but all i got this error msg :

 ![](https://us1.discourse-cdn.com/elastic/original/2X/6/61ab8ff514be1719976de4dbea6cb5050520a42b.png)

i dont understand, so i guess i need to change the json file that i got.  
i add several objects based on that error msg.  
i added this lines :

```
			"acknowledge":"true" ,
			"watcher":["Watcher will be disabled"],

			"security":["The following X-Pack security functionality will be disabled: authentication, authorization, ip filtering, and auditing. Please restart your node after applying the license.",
         "Field and document level access control will be disabled.",
         "Custom realms will be ignored."],

         	"monitoring":[  
         "Multi-cluster support is disabled for clusters with [BASIC] license. If you are\nrunning multiple clusters, users won't be able to access the clusters with\n[BASIC] licenses from within a single X-Pack Kibana instance. You will have to deploy a\nseparate and dedicated X-pack Kibana instance for each [BASIC] cluster you wish to monitor.",
         "Automatic index cleanup is locked to 7 days for clusters with [BASIC] license."
      		],

      	"graph":[  
         "Graph will be disabled"
      	]

```

but i still got the same error msg.  
can someone tell me whats going on here?  
is this feature only for subscription user or what?

i read the [Subscriptions | Elastic Stack Products & Support | Elastic](https://www.elastic.co/subscriptions)

i should be still can use at least the monitoring feature of xpack.  
or at least my xpack license should be updated.

what the heck is going on?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 8, 2017, 8:40pm UTC](https://discuss.elastic.co/t/upgrading-license-x-pack-failed/70894/2 "2017-01-08T20:40:05Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them 🙂

You need to run `curl -XPUT -u elastic 'http://localhost:9200/_xpack/license?acknowledge=true' -d @license_xpack.json`. See [https://www.elastic.co/guide/en/x-pack/current/installing-license.html](https://www.elastic.co/guide/en/x-pack/current/installing-license.html).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 5, 2017, 8:40pm UTC](https://discuss.elastic.co/t/upgrading-license-x-pack-failed/70894/3 "2017-02-05T20:40:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
