# Upgrading pains

**URL:** https://discuss.elastic.co/t/upgrading-pains/107644
**Category:** Kibana
**Created:** [November 14, 2017, 10:35pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644 "2017-11-14T22:35:44Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![dorj1234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorj1234/32/21339_2.png) [@dorj1234](https://discuss.elastic.co/u/dorj1234)
#### Post date: [November 14, 2017, 10:35pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644/1 "2017-11-14T22:35:44Z")

</div>

Hello,  
Just as feedback, I have to voice some frustration trying several paths to upgrade elastic/kibana/logstash.  
(CentOS, single node, nothing fancy)

Attempt #1: yum upgrade to latest 5.6.4, then using yum again to upgrade to 6  
Results - kibana re-index step number 2 (link and details below) in the upgrade page fail on the second step  
I ended up reverting the VM to prior state

Attemp #2: trying to install x-pack and registering basic license, in order to use x-pack UI for upgrades  
Results - destroyed my install, unusable, unreachable  
I ended up reverting the VM to prior state

Attemp #3: yum update from existing 5.6 (not latest) to 6 directly  
Results - reindex fails, no known way to fix  
I ended up reverting the VM to prior state

Attempt #4: trying #1 again, but really tired of those attempts. The reindex is killing it, and  
Step number 2 in this link is failing every time:  
[https://www.elastic.co/guide/en/kibana/6.0/migrating-6.0-index.html](https://www.elastic.co/guide/en/kibana/6.0/migrating-6.0-index.html)  
The line "index.mapping.single\_type": true" seems to be problematic,  
Any suggestions highly appreciated

Error from 2nd step of reindexing:  
"error" : {  
"root\_cause" : [  
{  
"type" : "illegal\_argument\_exception",  
"reason" : "unknown setting [index.mapping.single\_type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"  
}  
],  
"type" : "illegal\_argument\_exception",  
"reason" : "unknown setting [index.mapping.single\_type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"  
},  
"status" : 400  
}

---

<div class="post-metadata">

### Author: ![dorj1234](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dorj1234/32/21339_2.png) [@dorj1234](https://discuss.elastic.co/u/dorj1234)
#### Post date: [November 14, 2017, 10:40pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644/2 "2017-11-14T22:40:31Z")

</div>

Problem solved after I wrote this feedback, which is still important.  
The web page note is wrong, it says " If you are running a version prior to 5.6, you will need to omit index.format and index.mapping.single\_type from the second step."

Actually I had to omit those 2 entries even when running the latest 5.6

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [November 15, 2017, 7:15pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644/3 "2017-11-15T19:15:08Z")

</div>

> Attempt #1: yum upgrade to latest 5.6.4, then using yum again to upgrade to 6  
> Results - kibana re-index step number 2 (link and details below) in the upgrade page fail on the second step

`index.mapping.single_type` is only available in 5.6. I am [working on a PR](https://github.com/elastic/kibana/pull/14962) to address this for 6.0.

> Attempt #2: trying to install x-pack and registering basic license, in order to use x-pack UI for upgrades  
> Results - destroyed my install, unusable, unreachable

Can you give more information here? Did you upgrade to 5.6.4, or were you attempting to goto master? The Upgrade Assistant is available in the trial, so no immediate need to register the license.

> Attempt #3: yum update from existing 5.6 (not latest) to 6 directly  
> Results - reindex fails, no known way to fix

Can you give more information for this? You should be able to perform the manual reindex either prior to after the upgrade. index.mapping.single\_type is only available in 5.6, so it should be removed if your running a version other than that.

---

<div class="post-metadata">

### Author: ![Maekee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/maekee/32/21708_2.png) [@Maekee](https://discuss.elastic.co/u/Maekee)
#### Post date: [November 15, 2017, 8:07pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644/4 "2017-11-15T20:07:08Z")

</div>

Exactly what i found:

> [@Migrating the Kibana index](https://discuss.elastic.co/t/migrating-the-kibana-index/107749/3):
>
> Here is how i did it: [https://github.com/maekee/Elasticsearch/blob/master/Kibana/MigratingToKibana6.ps1](https://github.com/maekee/Elasticsearch/blob/master/Kibana/MigratingToKibana6.ps1)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 13, 2017, 8:07pm UTC](https://discuss.elastic.co/t/upgrading-pains/107644/5 "2017-12-13T20:07:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
