# Uptime error

**URL:** https://discuss.elastic.co/t/uptime-error/234791
**Category:** Synthetics
**Created:** [May 28, 2020, 5:38pm UTC](https://discuss.elastic.co/t/uptime-error/234791 "2020-05-28T17:38:21Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![h\_e\_m](https://avatars.discourse-cdn.com/v4/letter/h/b4bc9f/32.png) [@h\_e\_m](https://discuss.elastic.co/u/h_e_m)
#### Post date: [May 28, 2020, 5:38pm UTC](https://discuss.elastic.co/t/uptime-error/234791/1 "2020-05-28T17:38:21Z")

</div>

Hi!

I run elastic cloud with Kibana 7.6.1 since a few months, and my Uptime suddenly started to display

```auto
Error: [illegal_argument_exception] Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [monitor.id] in order to load field data by uninverting the inverted index. Note that this can use significant memory.

```

instead of the list of monitors. The graph show up fine thus.

It was working before and I have not changed the mapping created by Uptime when I set it up. The mapping for monitor.id is

```auto
        "monitor": {
...
            "id": {
              "type": "text",
              "fields": {
                "keyword": {
                  "type": "keyword",
                  "ignore_above": 256
                }
              }
            },

```

Any clues on how to get Uptime working is appreciated.  
Thanks

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [June 19, 2020, 12:39am UTC](https://discuss.elastic.co/t/uptime-error/234791/2 "2020-06-19T00:39:11Z")

</div>

Sorry to hear about this issue and apologies for the delay. It looks like an incorrect mapping has been applied. Typically this is caused by deleting the heartbeat indices while heartbeat is still running, causing default mappings to be applied by the next heartbeat write.

To fix this:

1. Stop all heartbeat instances
2. Delete all heartbeat indices
3. Start you heartbeat indices.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 13, 2020, 12:52am UTC](https://discuss.elastic.co/t/uptime-error/234791/3 "2020-07-13T00:52:37Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
