# Uptime errors when using CCS

**URL:** <https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248>\
**Category:** Synthetics\
**Created:** [June 16, 2020, 8:07am UTC](https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248 "2020-06-16T08:07:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![soysali](https://avatars.discourse-cdn.com/v4/letter/s/a88e57/32.png) [@soysali](https://discuss.elastic.co/u/soysali)\
**Post date:** [June 16, 2020, 8:07am UTC](https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248/1 "2020-06-16T08:07:26Z")

</div>

I installed and configured Heartbeat, Elasticsearch and Kibana 7.7, which works perfectly fine. I can see the resulting data on Uptime tab of Kibana. However I have other Elastic stack instances (also 7.7), so I have an Elasticsearch instance for cross-cluster search. I connected a Kibana instance to this Elasticsearch node.

The only thing I could not get working on this Kibana for cross-cluster search, is the Uptime function. The pie chart and pings over time graph works fine, but I cannot see the individual monitors in the table. There is the following error in the table:

`Error: [illegal_argument_exception] can not write type [class java.util.HashSet]`

Here is the screenshot of the issue:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/7/f70e9a02f0e6fa24118bc7c15484ff9659d7902b.png)

I am aware that a workaround could be to send Heartbeat data to this CCS node, however I do not want this, since it kind of messes up the structure I built.

EDIT: I would like to add that I added the heartbeat-\* index on the remote cluster in the settings page seen in the screenshot. I did the same thing with Logs and Metrics apps, which works without an issue. This one also works anyway, it's just the monitor status table is broken.

---

<div class="post-metadata">

**Author:** ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)\
**Post date:** [June 19, 2020, 12:37am UTC](https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248/2 "2020-06-19T00:37:29Z")

</div>

Thanks for the report. This is due to a scripted metric query that is currently in the process of being refactored away. See [this PR](https://github.com/elastic/kibana/pull/69229) for the work to remove it.

---

<div class="post-metadata">

**Author:** ![soysali](https://avatars.discourse-cdn.com/v4/letter/s/a88e57/32.png) [@soysali](https://discuss.elastic.co/u/soysali)\
**Post date:** [June 19, 2020, 7:49am UTC](https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248/3 "2020-06-19T07:49:35Z")

</div>

Thanks for your reply. Looking forward for a fixed release.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 13, 2020, 7:49am UTC](https://discuss.elastic.co/t/uptime-errors-when-using-ccs/237248/4 "2020-07-13T07:49:43Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
