# Uptime version 7.0 Graphql error

**URL:** https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661
**Category:** Synthetics
**Created:** [April 12, 2019, 3:28pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661 "2019-04-12T15:28:38Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![Luis\_Pereira1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/luis_pereira1/32/43046_2.png) [@Luis\_Pereira1](https://discuss.elastic.co/u/Luis_Pereira1)
#### Post date: [April 12, 2019, 3:28pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/1 "2019-04-12T15:28:39Z")

</div>

After the update to version 7.0 the uptime is giving me this error

 ![imagem](https://us1.discourse-cdn.com/elastic/original/3X/9/a/9ab485df969ae95942aee04c95d1400d064e04e0.png)

Any help is appreciated...

---

<div class="post-metadata">

### Author: ![jkambic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jkambic/32/53306_2.png) [@jkambic](https://discuss.elastic.co/u/jkambic)
#### Post date: [April 12, 2019, 7:12pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/2 "2019-04-12T19:12:01Z")

</div>

Hi @Luis_Pereira1- this is an issue we've run into a few times as well, it looks like the proper mappings for the Heartbeat index are not available. The `monitor.id` field should be of type `keyword` but in this case it seems like it is a `string` type, which is what Elasticsearch would choose as default.

You might try having Heartbeat [overwrite the existing template](https://www.elastic.co/guide/en/beats/heartbeat/current/heartbeat-template.html). Feel free to keep us apprised of your progress.

---

<div class="post-metadata">

### Author: ![mdibaiee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mdibaiee/32/44134_2.png) [@mdibaiee](https://discuss.elastic.co/u/mdibaiee)
#### Post date: [April 15, 2019, 8:49am UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/3 "2019-04-15T08:49:16Z")

</div>

Hi,

We are also experiencing the same issue.  
I tried using `heartbeat setup`, and the templates are indeed added to our Kibana dashboard under the name `heartbeat-7.0.0`, but I think the problem lies here:

The index used by Heartbeat for ElasticSearch is called `heartbeat-7.0.0`, without any daily dates in front, whereas the template has the following property:

```auto
index_patterns" : [
      "heartbeat-7.0.0-*"
    ],

```

Which doesn't match the original `heartbeat-7.0.0`, and so, again, Elasticsearch ignores this template.

I can't find the solution to this issue. The same happens for Metricbeat as well after upgrading to 7.0.0. We would very much appreciate a solution for this issue.

Here is the output of `heartbeat setup`:

```auto
2019-04-15T08:44:52.793Z INFO [index-management] idxmgmt/std.go:165 Set output.elasticsearch.index to 'heartbeat-7.0.0' as ILM is enabled.
2019-04-15T08:44:52.794Z INFO elasticsearch/client.go:165 Elasticsearch url: XXXXXXX
2019-04-15T08:44:52.794Z INFO [publisher] pipeline/module.go:97 Beat name: XXXX-heartbeat-zv4kh
2019-04-15T08:44:52.794Z INFO elasticsearch/client.go:165 Elasticsearch url: XXXXXXX
2019-04-15T08:44:52.799Z INFO add_cloud_metadata/add_cloud_metadata.go:345 add_cloud_metadata: hosting provider type detected as gce, metadata={"availability_zone":"us-central1-a","instance":{"id":"XXXXX","name":"gke-k8s-XXXXXX"},"machine":{"type":"n1-standard-4"},"project":{"id":"XXXXXX"},"provider":"gce"}
2019-04-15T08:44:52.847Z INFO elasticsearch/client.go:734 Attempting to connect to Elasticsearch version 7.0.0
2019-04-15T08:44:52.856Z INFO [index-management] idxmgmt/std.go:223 Auto ILM enable success.
2019-04-15T08:44:52.947Z INFO [index-management] idxmgmt/std.go:238 ILM policy successfully loaded.
2019-04-15T08:44:52.947Z INFO [index-management] idxmgmt/std.go:361 Set setup.template.name to '{heartbeat-7.0.0 {now/d}-000001}' as ILM is enabled.
2019-04-15T08:44:52.947Z INFO [index-management] idxmgmt/std.go:366 Set setup.template.pattern to 'heartbeat-7.0.0-*' as ILM is enabled.
2019-04-15T08:44:52.947Z INFO [index-management] idxmgmt/std.go:400 Set settings.index.lifecycle.rollover_alias in template to {heartbeat-7.0.0 {now/d}-000001} as ILM is enabled.
2019-04-15T08:44:52.948Z INFO [index-management] idxmgmt/std.go:404 Set settings.index.lifecycle.name in template to {heartbeat-7.0.0 map[policy:{"phases":{"hot":{"actions":{"rollover":{"max_age":"30d","max_size":"50gb"}}}}}]} as ILM is enabled.
2019-04-15T08:44:52.952Z INFO template/load.go:82 Loading template for Elasticsearch version: 7.0.0
2019-04-15T08:44:52.952Z INFO template/load.go:84 Existing template will be overwritten, as overwrite is enabled.
2019-04-15T08:44:53.134Z INFO template/load.go:145 Elasticsearch template with name 'heartbeat-7.0.0' loaded
2019-04-15T08:44:53.135Z INFO [index-management] idxmgmt/std.go:272 Loaded index template.
2019-04-15T08:44:53.149Z INFO [index-management] idxmgmt/std.go:281 Write alias exists already
Index setup complete.
Loading dashboards (Kibana must be running and reachable)
2019-04-15T08:44:53.149Z INFO kibana/client.go:118 Kibana url: XXXXX
2019-04-15T08:44:53.383Z INFO kibana/client.go:118 Kibana url: XXXX
Skipping loading dashboards, No directory /usr/share/heartbeat/kibana/7

```

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/8/583bc6a800c6eee59769562ee369762e21628623.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/e/6e3bc20f3069a000e060ef7fd41ef9051390d14e.png)

---

<div class="post-metadata">

### Author: ![mdibaiee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mdibaiee/32/44134_2.png) [@mdibaiee](https://discuss.elastic.co/u/mdibaiee)
#### Post date: [April 15, 2019, 8:58am UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/4 "2019-04-15T08:58:27Z")

</div>

I tried manually updating the template and changing `index_patterns` to `heartbeat-*` instead of `heartbeat-7.0.0-*`, and it works indeed.

So, it seems starting from Heartbeat 7.0.0, Index Lifecycle Management is enabled by default, which means there are no more daily indices and there are automatic rollovers instead. In that case, why does ILM set `setup.template.pattern = 'heartbeat-7.0.0-*`? It should be `heartbeat-7.0.0*`. Please correct me if I'm wrong. @jkambic

---

<div class="post-metadata">

### Author: ![mdibaiee](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mdibaiee/32/44134_2.png) [@mdibaiee](https://discuss.elastic.co/u/mdibaiee)
#### Post date: [April 22, 2019, 5:52pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/5 "2019-04-22T17:52:37Z")

</div>

Bump

---

<div class="post-metadata">

### Author: ![jkambic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jkambic/32/53306_2.png) [@jkambic](https://discuss.elastic.co/u/jkambic)
#### Post date: [April 24, 2019, 1:53pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/6 "2019-04-24T13:53:32Z")

</div>

@andrewvc do you have any thoughts on this? I've experienced this issue in development a few times as well, but the solution is much simpler in that case.

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [April 25, 2019, 9:30pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/7 "2019-04-25T21:30:43Z")

</div>

This appears to be a race affecting all beats. We're looking into the issue here: [https://github.com/elastic/beats/issues/11940](https://github.com/elastic/beats/issues/11940)

---

<div class="post-metadata">

### Author: ![Andrew\_Cholakian1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrew_cholakian1/32/3612_2.png) [@Andrew\_Cholakian1](https://discuss.elastic.co/u/Andrew_Cholakian1)
#### Post date: [April 30, 2019, 5:10pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/8 "2019-04-30T17:10:36Z")

</div>

I've updated the Github issue here [https://github.com/elastic/beats/issues/11940](https://github.com/elastic/beats/issues/11940) with the root cause and a workaround. Please track the issue for further updates.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 24, 2019, 5:10pm UTC](https://discuss.elastic.co/t/uptime-version-7-0-graphql-error/176661/9 "2019-05-24T17:10:38Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
