# URL of the Elasticsearch instance

**URL:** <https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881>\
**Category:** Kibana\
**Created:** [January 8, 2017, 3:45pm UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881 "2017-01-08T15:45:24Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 8, 2017, 3:45pm UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/1 "2017-01-08T15:45:24Z")

</div>

After applying all security,

If I set the URL of the Elasticsearch instance  
elasticsearch.url: " **https** ://localhost:9200" in kibana.yml, the kibana browser isn't starting.

When using back:  
elasticsearch.url: "[http://localhost:9200](http://localhost:9200)"

The kibana browser is working.

What is wrong?

Regards,  
Sharon.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 8, 2017, 8:06pm UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/2 "2017-01-08T20:06:43Z")

</div>

What do the logs say?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 6:57am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/3 "2017-01-09T06:57:56Z")

</div>

Which log should I check? The kibana's one?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 9, 2017, 7:02am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/4 "2017-01-09T07:02:12Z")

</div>

Yep.

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 7:16am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/5 "2017-01-09T07:16:55Z")

</div>

Ok, I tail the log during running and trying to open the kibana's web, and that's what I saw:

**1. When running the kibana**

```
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["status","plugin:kibana@5.0.1","info"],"pid":2829,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"u
ninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["status","plugin:elasticsearch@5.0.1","info"],"pid":2829,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for
Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["status","plugin:xpack_main@5.0.1","info"],"pid":2829,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Ela
sticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["error","elasticsearch"],"pid":2829,"message":"Request error, retrying\nHEAD https://localhost:9200/ => write EPROTO 140655888361280:error:1407
70FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:../deps/openssl/openssl/ssl/s23_clnt.c:794:\n"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["warning","elasticsearch"],"pid":2829,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["warning","elasticsearch"],"pid":2829,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["status","plugin:xpack_main@5.0.1","error"],"pid":2829,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elasti
csearch at https://localhost:9200.","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["status","plugin:elasticsearch@5.0.1","error"],"pid":2829,"state":"red","message":"Status changed from yellow to red - Unable to connect to Ela
sticsearch at https://localhost:9200.","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:graph@5.0.1","error"],"pid":2829,"state":"red","message":"Status changed from uninitialized to red - Unable to connect to Elas
ticsearch at https://localhost:9200.","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:monitoring@5.0.1","info"],"pid":2829,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState
":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["reporting","warning"],"pid":2829,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing
 on restart, please set xpack.reporting.encryptionKey in kibana.yml"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:reporting@5.0.1","error"],"pid":2829,"state":"red","message":"Status changed from uninitialized to red - Unable to connect to
Elasticsearch at https://localhost:9200.","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:security@5.0.1","error"],"pid":2829,"state":"red","message":"Status changed from uninitialized to red - Unable to connect to E
lasticsearch at https://localhost:9200.","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["security","warning"],"pid":2829,"message":"Session cookies will be transmitted over insecure connections. This is not recommended."}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["warning","elasticsearch"],"pid":2829,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["warning","elasticsearch"],"pid":2829,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:console@5.0.1","info"],"pid":2829,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"
uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","plugin:timelion@5.0.1","info"],"pid":2829,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":
"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["listening","info"],"pid":2829,"message":"Server running at http://0.0.0.0:5601"}
{"type":"log","@timestamp":"2017-01-09T07:08:56Z","tags":["status","ui settings","error"],"pid":2829,"state":"red","message":"Status changed from uninitialized to red - Elasticsearch plugin is red","pr
evState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-01-09T07:08:58Z","tags":["warning","elasticsearch"],"pid":2829,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-09T07:08:58Z","tags":["warning","elasticsearch"],"pid":2829,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-09T07:08:59Z","tags":["warning","elasticsearch"],"pid":2829,"message":"Unable to revive connection: https://localhost:9200/"}
```

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 7:17am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/6 "2017-01-09T07:17:32Z")

</div>

**2. When trying to connect with the browser:**

```
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/app/kibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":26,"contentLength":9},"message":"GET /app/kibana 302 26ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/login?next=%2Fapp%2Fkibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":4,"contentLength":9},"message":"GET /login?next=%2Fapp%2Fkibana 302 4ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/app/kibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":3,"contentLength":9},"message":"GET /app/kibana 302 3ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/login?next=%2Fapp%2Fkibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":1,"contentLength":9},"message":"GET /login?next=%2Fapp%2Fkibana 302 1ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/app/kibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":2,"contentLength":9},"message":"GET /app/kibana 302 2ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:10Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/login?next=%2Fapp%2Fkibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":1,"contentLength":9},"message":"GET /login?next=%2Fapp%2Fkibana 302 1ms - 9.0B"}
{"type":"response","@timestamp":"2017-01-09T07:09:11Z","tags":[],"pid":2829,"method":"get","statusCode":302,"req":{"url":"/app/kibana","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","cache-control":"max-age=0","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":4,"contentLength":9},"message":"GET /app/kibana 302 4ms - 9.0B"}
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 9, 2017, 7:20am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/7 "2017-01-09T07:20:31Z")

</div>

> [@ssasporta](#):
>
> {"type":"log","@timestamp":"2017-01-09T07:08:55Z","tags":["error","elasticsearch"],"pid":2829,"message":"Request error, retrying\nHEAD [https://localhost:9200/](https://localhost:9200/) =\> write EPROTO 140655888361280:error:1407  
> 70FC:SSL routines:SSL23\_GET\_SERVER\_HELLO:unknown protocol:../deps/openssl/openssl/ssl/s23\_clnt.c:794:\n"}

Can you curl the ES host on https without error?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 7:46am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/8 "2017-01-09T07:46:27Z")

</div>

> [@warkolm](#):
>
> curl the ES host on https

mpswrk1@eaasrt!MPS:/var/log\> curl [https://localhost:9200](https://localhost:9200)  
curl: (35) SSL received a record that exceeded the maximum permissible length.

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 8:32am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/9 "2017-01-09T08:32:58Z")

</div>

Hi Mark, What should I do now?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 9, 2017, 9:29am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/10 "2017-01-09T09:29:26Z")

</div>

One more thing, I also have a problem with the file:

server.ssl.cert: /usr/share/kibana/optimize/kibanacrt.crt

When that entry is uncommented in the kibana/yml, the kibana browser isn't starting too, and I am getting the following in the kibana.log:

`{"type":"response","@timestamp":"2017-01-09T09:21:34Z","tags":[],"pid":8079,"method":"get","statusCode":302,"req":{"url":"/login?next=%2Fapp%2Fkibana%23%2Fdiscover%2Fweblogic_logs-28-12%3F_g%3D(refreshInterval%3A(display%3AOff%2Cpause%3A!f%2Cvalue%3A0)%2Ctime%3A(from%3A'2016-02-15T19%3A15%3A41.205Z'%2Cmode%3Aabsolute%2Cto%3A'2016-03-05T19%3A15%3A41.205Z'))%26_a%3D(columns%3A!(_source)%2Cfilters%3A!()%2Cindex%3A'logstash-*'%2Cinterval%3Aauto%2Cquery%3A(query_string%3A(analyze_wildcard%3A!t%2Cquery%3A'*'))%2Csort%3A!('%40timestamp'%2Cdesc))&msg=SESSION_EXPIRED","method":"get","headers":{"host":"10.235.81.127:5601","connection":"keep-alive","upgrade-insecure-requests":"1","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36","accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8","accept-encoding":"gzip, deflate, sdch","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.242.52.166","userAgent":"10.242.52.166"},"res":{"statusCode":302,"responseTime":18,"contentLength":9},"message":"GET /login?next=%2Fapp%2Fkibana%23%2Fdiscover%2Fweblogic_logs-28-12%3F_g%3D(refreshInterval%3A(display%3AOff%2Cpause%3A!f%2Cvalue%3A0)%2Ctime%3A(from%3A'2016-02-15T19%3A15%3A41.205Z'%2Cmode%3Aabsolute%2Cto%3A'2016-03-05T19%3A15%3A41.205Z'))%26_a%3D(columns%3A!(_source)%2Cfilters%3A!()%2Cindex%3A'logstash-*'%2Cinterval%3Aauto%2Cquery%3A(query_string%3A(analyze_wildcard%3A!t%2Cquery%3A'*'))%2Csort%3A!('%40timestamp'%2Cdesc))&msg=SESSION_EXPIRED 302 18ms - 9.0B"}`

Are these two issues connected ?

Thanks  
Sharon.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 6, 2017, 9:29am UTC](https://discuss.elastic.co/t/url-of-the-elasticsearch-instance/70881/11 "2017-02-06T09:29:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
