# Use case exception

**URL:** <https://discuss.elastic.co/t/use-case-exception/336750>\
**Category:** Elastic Security\
**Created:** [June 23, 2023, 8:52am UTC](https://discuss.elastic.co/t/use-case-exception/336750 "2023-06-23T08:52:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![PerfectSushi](https://avatars.discourse-cdn.com/v4/letter/p/919ad9/32.png) [@PerfectSushi](https://discuss.elastic.co/u/PerfectSushi)\
**Post date:** [June 23, 2023, 8:52am UTC](https://discuss.elastic.co/t/use-case-exception/336750/1 "2023-06-23T08:52:29Z")

</div>

Dear team,

I am currently facing some challenges while attempting to create a correlated use case involving the prebuilt "Whoami Process Activity." The issue arises because we need to make an exception for a previous log that generates this activity. Specifically, it is a PowerShell script that executes the "whoami" validation.

sequence with maxspan=2s  
[process where process.args: "\*"]  
[process where event.type in ("start", "process\_started") and process.name: "whoami.exe"]

Currently, when I attempt to use the query NOT "process where not process.args:", it does not seem to be functioning correctly.

I would greatly appreciate your assistance in this matter. Could you please help me understand what I might be doing wrong?

Best regards,

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 21, 2023, 8:53am UTC](https://discuss.elastic.co/t/use-case-exception/336750/2 "2023-07-21T08:53:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
