# Users with any role (except superuser) cannot view events in kibana

**URL:** https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617
**Category:** Kibana
**Created:** [July 3, 2017, 10:49am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617 "2017-07-03T10:49:20Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mkain](https://avatars.discourse-cdn.com/v4/letter/m/ba8739/32.png) [@mkain](https://discuss.elastic.co/u/mkain)
#### Post date: [July 3, 2017, 10:49am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617/1 "2017-07-03T10:49:20Z")

</div>

Hi,

```
I have managed to install x-pack plugin on ELK 5.4.1. When I have created a user "guest" with "kibana_user" role. But after getting into kibana no events are visible to the user. 

```

I can see same behavior with other roles except superuser. I have tried to collect to elasticsearch via curl using these users/passwords and I do get response.

What else I have to tune ? any file system level permissions have to be changed ?

curl -u guest:xxxxx [http://localhost:9200](http://localhost:9200)  
{  
"name" : "Q2FAvfq",  
"cluster\_name" : "elas-541",  
"cluster\_uuid" : "7MtPg0oQSaWdlw4OKHojCg",  
"version" : {  
"number" : "5.4.1",  
"build\_hash" : "2cfe0df",  
"build\_date" : "2017-05-29T16:05:51.443Z",  
"build\_snapshot" : false,  
"lucene\_version" : "6.5.1"  
},  
"tagline" : "You Know, for Search"  
}

Regards,  
-Manish

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [July 3, 2017, 10:52am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617/2 "2017-07-03T10:52:42Z")

</div>

Have you assigned these users the `kibana_user` role?

---

<div class="post-metadata">

### Author: ![mkain](https://avatars.discourse-cdn.com/v4/letter/m/ba8739/32.png) [@mkain](https://discuss.elastic.co/u/mkain)
#### Post date: [July 5, 2017, 3:55am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617/3 "2017-07-05T03:55:44Z")

</div>

> > Have you assigned these users the kibana\_user role?

Yes off course I had. But today I spotted another error in logstash. I suspect x-pack may be the cause "[Index 404 error in logstash](https://discuss.elastic.co/t/index-404-error-in-logstash/91830)" but even after removing x-pack I continue to get 404 error during indexing in logstash.

Regards,  
-Manish

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 2, 2017, 3:56am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617/4 "2017-08-02T03:56:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
