# Users with any role (except superuser) cannot view events in kibana

**URL:** https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617
**Category:** Kibana
**Created:** [July 3, 2017, 10:49am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617 "2017-07-03T10:49:20Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![mkain](https://avatars.discourse-cdn.com/v4/letter/m/ba8739/32.png) [@mkain](https://discuss.elastic.co/u/mkain)
#### Post date: [July 5, 2017, 3:55am UTC](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617/3 "2017-07-05T03:55:44Z")

</div>

> > Have you assigned these users the kibana\_user role?

Yes off course I had. But today I spotted another error in logstash. I suspect x-pack may be the cause "[Index 404 error in logstash](https://discuss.elastic.co/t/index-404-error-in-logstash/91830)" but even after removing x-pack I continue to get 404 error during indexing in logstash.

Regards,  
-Manish

---

_[View the full topic](https://discuss.elastic.co/t/users-with-any-role-except-superuser-cannot-view-events-in-kibana/91617)._
