# Using tags

**URL:** https://discuss.elastic.co/t/using-tags/14367
**Category:** Elasticsearch
**Created:** [November 12, 2013, 7:32pm UTC](https://discuss.elastic.co/t/using-tags/14367 "2013-11-12T19:32:00Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)
#### Post date: [November 12, 2013, 7:32pm UTC](https://discuss.elastic.co/t/using-tags/14367/1 "2013-11-12T19:32:00Z")

</div>

I am trying to use tags as explained here:

[http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html)

When I add "node.group1: group1" to my elasticsearch.yml file and start es  
I get. Is this not how I am supposed to define the groups?

[root@ip-10-80-140-242 ~]# {0.90.6}: Setup Failed ...

- SettingsException[Failed to load settings from  
[file:/etc/elasticsearch/elasticsearch.yml]]

ParserException[while parsing a block mapping; expected , but  
found BlockMappingStart]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![javanna](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/javanna/32/4698_2.png) [@javanna](https://discuss.elastic.co/u/javanna)
#### Post date: [November 13, 2013, 2:36pm UTC](https://discuss.elastic.co/t/using-tags/14367/2 "2013-11-13T14:36:40Z")

</div>

Did you use the quotes in your configuration file? Where did you place the  
node attribute exactly?

On Tuesday, November 12, 2013 8:32:00 PM UTC+1, Mo wrote:

> I am trying to use tags as explained here:
> 
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-allocation.html)
> 
> When I add "node.group1: group1" to my elasticsearch.yml file and start es  
> I get. Is this not how I am supposed to define the groups?
> 
> [root@ip-10-80-140-242 ~]# {0.90.6}: Setup Failed ...
> 
> - SettingsException[Failed to load settings from  
> [file:/etc/elasticsearch/elasticsearch.yml]]
> 
> ParserException[while parsing a block mapping; expected , but  
> found BlockMappingStart]

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![Mohit\_Anchlia](https://avatars.discourse-cdn.com/v4/letter/m/848f3c/32.png) [@Mohit\_Anchlia](https://discuss.elastic.co/u/Mohit_Anchlia)
#### Post date: [November 13, 2013, 8:16pm UTC](https://discuss.elastic.co/t/using-tags/14367/3 "2013-11-13T20:16:11Z")

</div>

I figured out the problem eventually. The issue was an extra whitespace in  
the begining 🙂

On Wed, Nov 13, 2013 at 6:36 AM, Luca Cavanna [cavannaluca@gmail.com](mailto:cavannaluca@gmail.com) wrote:

> Did you use the quotes in your configuration file? Where did you place the  
> node attribute exactly?
> 
> On Tuesday, November 12, 2013 8:32:00 PM UTC+1, Mo wrote:
> 
> > I am trying to use tags as explained here:
> > 
> > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/en/elasticsearch/)  
> > reference/current/index-modules-allocation.html
> > 
> > When I add "node.group1: group1" to my elasticsearch.yml file and start  
> > es I get. Is this not how I am supposed to define the groups?
> > 
> > [root@ip-10-80-140-242 ~]# {0.90.6}: Setup Failed ...
> > 
> > - SettingsException[Failed to load settings from [file:/etc/elasticsearch/  
> > elasticsearch.yml]]
> > 
> > ParserException[while parsing a block mapping; expected , but  
> > found BlockMappingStart]
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 2:07am UTC](https://discuss.elastic.co/t/using-tags/14367/4 "2017-07-06T02:07:23Z")

</div>


