# Using the heartbeat (6.8.3) keystore prevents heartbeat windows service starting

**URL:** <https://discuss.elastic.co/t/using-the-heartbeat-6-8-3-keystore-prevents-heartbeat-windows-service-starting/267353>\
**Category:** Beats\
**Tags:** heartbeat\
**Created:** [March 16, 2021, 11:06am UTC](https://discuss.elastic.co/t/using-the-heartbeat-6-8-3-keystore-prevents-heartbeat-windows-service-starting/267353 "2021-03-16T11:06:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![halltony](https://avatars.discourse-cdn.com/v4/letter/h/87869e/32.png) [@halltony](https://discuss.elastic.co/u/halltony)\
**Post date:** [March 16, 2021, 11:06am UTC](https://discuss.elastic.co/t/using-the-heartbeat-6-8-3-keystore-prevents-heartbeat-windows-service-starting/267353/1 "2021-03-16T11:06:45Z")

</div>

I am trying to use the heartbeat keystore to store credentials used to authenticate with my Elastic Search cluster. The configuration works fine when run from a command line but when I use it via a windows service the service will not start. The error is Error 1053: The service did not respond to the start or control request in a timely fashion. The service was created as per the instructions on the heartbeat documentation using the supplied install powershell script.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 13, 2021, 1:07pm UTC](https://discuss.elastic.co/t/using-the-heartbeat-6-8-3-keystore-prevents-heartbeat-windows-service-starting/267353/2 "2021-04-13T13:07:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
