# Using the Truncate filter on keywords

**URL:** https://discuss.elastic.co/t/using-the-truncate-filter-on-keywords/153476
**Category:** Elasticsearch
**Created:** [October 22, 2018, 8:04pm UTC](https://discuss.elastic.co/t/using-the-truncate-filter-on-keywords/153476 "2018-10-22T20:04:08Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![Fayaz](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@Fayaz](https://discuss.elastic.co/u/Fayaz)
#### Post date: [November 13, 2018, 7:33am UTC](https://discuss.elastic.co/t/using-the-truncate-filter-on-keywords/153476/6 "2018-11-13T07:33:13Z")

</div>

I am also looking for solution to this problem. Elasticsearch 6 has increased ignore\_above limit [https://www.elastic.co/guide/en/elasticsearch/reference/current/keyword.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/keyword.html). But underlying lucene limit is still 32766 and elasticsearch fails with "Document contains at least one immense term in" error. It seems elasticsearch community has no solution to this problem : [ElasticSearch 6.2.4 java.lang.IllegalArgumentException: Document contains at least one immense term](https://discuss.elastic.co/t/elasticsearch-6-2-4-java-lang-illegalargumentexception-document-contains-at-least-one-immense-term/154122).

---

_[View the full topic](https://discuss.elastic.co/t/using-the-truncate-filter-on-keywords/153476)._
