# V6.3 - cannot set default index & constant 400 errors

**URL:** https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582
**Category:** Kibana
**Created:** [September 6, 2018, 1:25pm UTC](https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582 "2018-09-06T13:25:27Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![violetaria](https://avatars.discourse-cdn.com/v4/letter/v/3bc359/32.png) [@violetaria](https://discuss.elastic.co/u/violetaria)
#### Post date: [September 6, 2018, 1:25pm UTC](https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582/1 "2018-09-06T13:25:27Z")

</div>

I'm using Kibana 6.3 running in Kubernetes and I keep getting errors about the defaultIndex

If I add more than 1 index, the whole UI stops functioning and complains about having a default index set.

Every page load throws this error in the dev tools network tab:  
`{"message":"failed to parse [config.defaultIndex]: [mapper_parsing_exception] failed to parse [config.defaultIndex]","statusCode":400,"error":"Bad Request"}`

I cannot set a default Index via the UI, I set it and it ignores the setting/throws a 400 error in the UI (Config: Request failed with status code: 400)

This is my first experience with Kibana and I'm not sure how to fix this, any help would be greatly appreciated.

---

<div class="post-metadata">

### Author: ![ppisljar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppisljar/32/11588_2.png) [@ppisljar](https://discuss.elastic.co/u/ppisljar)
#### Post date: [September 6, 2018, 1:31pm UTC](https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582/2 "2018-09-06T13:31:44Z")

</div>

looks like something went wrong with the instalation.

could you copy paste the request and response chrome gets when setting the default index (from chrome developer tools)

---

<div class="post-metadata">

### Author: ![violetaria](https://avatars.discourse-cdn.com/v4/letter/v/3bc359/32.png) [@violetaria](https://discuss.elastic.co/u/violetaria)
#### Post date: [September 6, 2018, 1:36pm UTC](https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582/3 "2018-09-06T13:36:19Z")

</div>

I think you are right!

I found another person on here that mentioned deleting the .kibana index from elastic search. I tried that and it seemed to fix the issue. I'm not the person who originally got the instances up so not sure what went wrong, but I am good to go now.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 4, 2018, 1:36pm UTC](https://discuss.elastic.co/t/v6-3-cannot-set-default-index-constant-400-errors/147582/4 "2018-10-04T13:36:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
