# V7.6.0 kibana port 5601 connection refused

**URL:** https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587
**Category:** Kibana
**Tags:** docker
**Created:** [March 1, 2020, 5:21pm UTC](https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587 "2020-03-01T17:21:26Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![AaronYe](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@AaronYe](https://discuss.elastic.co/u/AaronYe)
#### Post date: [March 1, 2020, 5:21pm UTC](https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587/1 "2020-03-01T17:21:26Z")

</div>

Hello，I install elasticsearch,kibana with docker by using official documentation.  
My OS is centos 7.7 and elastisearch and kibana is v7.6.0.  
The docker-compose.yml configuration is shown below:

> version: '2.2'  
> services:  
> es76:  
> image: [docker.elastic.co/elasticsearch/elasticsearch:7.6.0](http://docker.elastic.co/elasticsearch/elasticsearch:7.6.0)  
> container\_name: es76  
> environment:  
> - node.name=es76  
> - cluster.name=es-docker-cluster  
> - cluster.initial\_master\_nodes=es76  
> - bootstrap.memory\_lock=true  
> - "ES\_JAVA\_OPTS=-Xms1g -Xmx1g"  
> ulimits:  
> memlock:  
> soft: -1  
> hard: -1  
> volumes:  
> - ./data76:/usr/share/elasticsearch/data  
> ports:  
> - 9200:9200  
> networks:  
> - elastic  
> kibana:  
> image: [docker.elastic.co/kibana/kibana:7.6.0](http://docker.elastic.co/kibana/kibana:7.6.0)  
> volumes:  
> - ./kibana/kibana.yml:/usr/share/kibana/config/kibana.yml  
> ports:  
> - "5601:5601"  
> networks:  
> - elastic  
> # cerebro:  
> # image: lmenezes/cerebro:0.8.3  
> # container\_name: cerebro  
> # ports:  
> # - "9000:9000"  
> # command:  
> # - -Dhosts.0.host=[http://es76:9200](http://es76:9200)  
> volumes:  
> data76:  
> driver: local  
> networks:  
> elastic:  
> driver: bridge

kibana.yml：

> server.name: kibana  
> server.host: "0.0.0.0"  
> elasticsearch.hosts: ["[http://es76:9200](http://es76:9200)" ]  
> xpack.monitoring.ui.container.elasticsearch.enabled: true

when I use the docker-compose up -d，elasticsearch and kibana is running。  
but when I access kibana with Google Chrome, the url is "[http://localhost:5601](http://localhost:5601)".Then I find that the connection is refused。

> netstat -natp | grep 5601  
> tcp6 0 0 :::5601 :::\* LISTEN 10872/docker-proxy-  
> netstat -natp | grep 9200  
> tcp6 0 0 :::9200 :::\* LISTEN 10857/docker-proxy-

what should I do?  
please help me  
thank you

---

<div class="post-metadata">

### Author: ![Aaron\_Caldwell](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron_caldwell/32/45755_2.png) [@Aaron\_Caldwell](https://discuss.elastic.co/u/Aaron_Caldwell)
#### Post date: [March 2, 2020, 5:08pm UTC](https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587/2 "2020-03-02T17:08:46Z")

</div>

Hello Aaron,

This looks likely to be a docker-specific network setup issue. It might be worth reviewing [this docker compose](https://github.com/elastic/docker-elastic/blob/master/docker-compose.yml) for reference. If this doesn't help, there may be an issue specific to running Docker on your OS that requires specific network settings.

Regards,  
Aaron

---

<div class="post-metadata">

### Author: ![AaronYe](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@AaronYe](https://discuss.elastic.co/u/AaronYe)
#### Post date: [March 3, 2020, 3:51pm UTC](https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587/3 "2020-03-03T15:51:43Z")

</div>

I have set up the network again and it is working normally, thank you very much.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 31, 2020, 3:51pm UTC](https://discuss.elastic.co/t/v7-6-0-kibana-port-5601-connection-refused/221587/4 "2020-03-31T15:51:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
