# Vega Visualizations in Kibana: 400 error setting default pattern

**URL:** <https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808>\
**Category:** Elastic Training\
**Created:** [March 30, 2021, 2:55pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808 "2021-03-30T14:55:23Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jonahzirkle](https://avatars.discourse-cdn.com/v4/letter/j/8c91f0/32.png) [@jonahzirkle](https://discuss.elastic.co/u/jonahzirkle)\
**Post date:** [March 30, 2021, 2:55pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/1 "2021-03-30T14:55:23Z")

</div>

Class/lab has me create index patterns; which works fine. I cannot proceed to the next step of going to Discover w/o setting a default pattern. When I click the start, for either pattern, a 400 error is throw w/an exception. I've also tried manually setting in advanced settings and dev tools to the .kibana index w/o success.

This thread had the exact issue but was auto-closed. Please assist.

---

<div class="post-metadata">

**Author:** ![mimitsu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mimitsu/32/63074_2.png) [@mimitsu](https://discuss.elastic.co/u/mimitsu)\
**Post date:** [March 30, 2021, 5:31pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/2 "2021-03-30T17:31:10Z")

</div>

Hi @jonahzirkle! Can you try deleting the .kibana index?

To do this:

- Go to Dev Tools on the left panel.
- Copy-paste this: `DELETE .kibana` then click the Apply button (sideways triangle)

Now go back to Management\>Index Pattern and try to create the two index patterns again.

---

<div class="post-metadata">

**Author:** ![dschneiter](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dschneiter/32/46162_2.png) [@dschneiter](https://discuss.elastic.co/u/dschneiter)\
**Post date:** [March 30, 2021, 7:25pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/3 "2021-03-30T19:25:44Z")

</div>

Hi @jonahzirkle

Before deleting the .kibana-index I would try a different approach.

1. Create the index pattern
2. Set it as default index pattern
3. Refresh your browser

I'm not sure what exact problem you are facing, but often index-pattern-related issues are caused by caching issue in web browsers.

Let me know whether that helped.

Cheers, Daniel

---

<div class="post-metadata">

**Author:** ![jonahzirkle](https://avatars.discourse-cdn.com/v4/letter/j/8c91f0/32.png) [@jonahzirkle](https://discuss.elastic.co/u/jonahzirkle)\
**Post date:** [March 31, 2021, 4:18pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/4 "2021-03-31T16:18:53Z")

</div>

This took care of it. Thank you!

---

<div class="post-metadata">

**Author:** ![jonahzirkle](https://avatars.discourse-cdn.com/v4/letter/j/8c91f0/32.png) [@jonahzirkle](https://discuss.elastic.co/u/jonahzirkle)\
**Post date:** [March 31, 2021, 4:20pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/5 "2021-03-31T16:20:55Z")

</div>

1. Step 1 was fine.
2. Would not auto set or allow me to set as default. Thus the 400 error.
3. Refreshed, deleted patterns and tried again. Ingested other data and tried on that and same result.

The fix ended up being to delete .kibana and start over. It immediately assigned the first pattern as the default.

Appreciate your time and input.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 30, 2021, 4:21pm UTC](https://discuss.elastic.co/t/vega-visualizations-in-kibana-400-error-setting-default-pattern/268808/6 "2021-04-30T16:21:26Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
