# Version 7.1.1 Amazing thing. Director become file After a power failure

**URL:** https://discuss.elastic.co/t/version-7-1-1-amazing-thing-director-become-file-after-a-power-failure/205990
**Category:** Elasticsearch
**Created:** [October 31, 2019, 6:59am UTC](https://discuss.elastic.co/t/version-7-1-1-amazing-thing-director-become-file-after-a-power-failure/205990 "2019-10-31T06:59:38Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![panxuelin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/panxuelin/32/56743_2.png) [@panxuelin](https://discuss.elastic.co/u/panxuelin)
#### Post date: [October 31, 2019, 6:59am UTC](https://discuss.elastic.co/t/version-7-1-1-amazing-thing-director-become-file-after-a-power-failure/205990/1 "2019-10-31T06:59:38Z")

</div>

After power off system while writing and start elasticsearch

Caused by: org.elasticsearch.gateway.WriteStateException: failed to open state directory /disks/data5/elasticsearch/nodes/0/indices/PQDYiAG4SV2bc9Wrt59T8A/\_state  
at org.elasticsearch.gateway.MetaDataStateFormat.write(MetaDataStateFormat.java:239) ~[elasticsearch-7.1.1.jar:7.1.1]  
at org.elasticsearch.gateway.MetaDataStateFormat.write(MetaDataStateFormat.java:209) ~[elasticsearch-7.1.1.jar:7.1.1]  
at org.elasticsearch.gateway.MetaStateService.writeIndex(MetaStateService.java:224) ~[elasticsearch-7.1.1.jar:7.1.1]  
... 16 more  
Caused by: java.nio.file.FileSystemException: /disks/data5/elasticsearch/nodes/0/indices/PQDYiAG4SV2bc9Wrt59T8A/\_state: Not a directory  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:91) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:?]  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:?]  
at sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:384) ~[?:?]  
at java.nio.file.Files.createDirectory(Files.java:674) ~[?:1.8.0\_201]  
at java.nio.file.Files.createAndCheckIsDirectory(Files.java:781) ~[?:1.8.0\_201]  
at java.nio.file.Files.createDirectories(Files.java:767) ~[?:1.8.0\_201]  
at org.apache.lucene.store.FSDirectory.(FSDirectory.java:157) ~[lucene-core-8.0.0.jar:8.0.0 2ae4746365c1ee72a0047ced7610b2096e438979 - jimczi

drwxr-xr-x 3 elasticsearch elasticsearch 4096 Oct 12 09:23 fbhBoVdFQceJg0\_Gqno7kw  
drwxr-xr-x 4 elasticsearch elasticsearch 4096 Oct 12 09:23 ff7IJZkJTGirPkUW6iXfcA  
drwxr-xr-x 3 elasticsearch elasticsearch 4096 Oct 12 09:23 fiIAl-MHRT-q8m8vWv1ZGA  
drwxr-xr-x 3 elasticsearch elasticsearch 4096 Oct 12 09:23 FiLw3CzhTjizG9og6O6m4w  
drwxr-xr-x 3 elasticsearch elasticsearch 4096 Oct 12 09:23 FkqpJIydR0-wZ-F4bMsKrA  
-rw-r--r-- 1 elasticsearch elasticsearch 598 Oct 12 09:23 FKYr1AGQQ3-Ori91xmHRHA

just see the last one. It become a file. But the problem just come once.

---

<div class="post-metadata">

### Author: ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)
#### Post date: [October 31, 2019, 7:28am UTC](https://discuss.elastic.co/t/version-7-1-1-amazing-thing-director-become-file-after-a-power-failure/205990/2 "2019-10-31T07:28:02Z")

</div>

As discussed here, your disks have a volatile write cache that loses (and apparently corrupts) data on a power loss:

> [@Version 7.1.1 Corrupted translog After a power failure](https://discuss.elastic.co/t/version-7-1-1-corrupted-translog-after-a-power-failure/205968/12):
>
> No, this does not indicate a problem in Elasticsearch or elsewhere. It indicates that your disks have a volatile write cache that loses data on a power loss.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 28, 2019, 7:28am UTC](https://discuss.elastic.co/t/version-7-1-1-amazing-thing-director-become-file-after-a-power-failure/205990/3 "2019-11-28T07:28:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
