# Viewing Metrics -- 500 Internal Server Error

**URL:** <https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501>\
**Category:** Metrics\
**Created:** [March 28, 2020, 5:21pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501 "2020-03-28T17:21:46Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![eugeneswalker](https://avatars.discourse-cdn.com/v4/letter/e/6de8d8/32.png) [@eugeneswalker](https://discuss.elastic.co/u/eugeneswalker)\
**Post date:** [March 28, 2020, 5:21pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/1 "2020-03-28T17:21:47Z")

</div>

I'm using ELK 7.6.1, all running on the same physical node as docker containers, launched via a docker-compose file. The only shipper setup so far is Filebeat for sending system logs. I can view these in Kibana. The problem is, when I try to bring up the Metrics page in Kibana UI, I am getting a pop-up in the lower right side of screen saying

```auto
Error while fetching resource
Error: Internal Server Error (500)
URL: http://instinct.nic.uoregon.edu:5601/api/metrics/snapshot

```

**This is my browser console error:**

```auto
POST http://instinct.nic.uoregon.edu:5601/api/metrics/snapshot 500 (Internal Server Error)

commons.bundle.js:3 Uncaught (in promise) Error: Internal Server Error
    at fetchResponse$ (commons.bundle.js:3)
    at s (kbn-ui-shared-deps.js:338)
    at Generator._invoke (kbn-ui-shared-deps.js:338)
    at Generator.forEach.e.<computed> [as next] (kbn-ui-shared-deps.js:338)
    at s (kbn-ui-shared-deps.js:338)
    at t (kbn-ui-shared-deps.js:338)
    at kbn-ui-shared-deps.js:338

```

**Server log**

```auto
$> docker logs -f elk_kibana_1 | grep 500
...
{"type":"response","@timestamp":"2020-03-28T17:04:17Z","tags":["access:infra"],"pid":6,"method":"post","statusCode":500,"req":{"url":"/api/metrics/snapshot","method":"post","headers":{"host":"instinct.nic.uoregon.edu:5601","connection":"keep-alive","content-length":"193","kbn-version":"7.6.1","user-agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36","content-type":"application/json","accept":"*/*","origin":"http://instinct.nic.uoregon.edu:5601","referer":"http://instinct.nic.uoregon.edu:5601/app/infra","accept-encoding":"gzip, deflate","accept-language":"en-US,en;q=0.9"},"remoteAddress":"73.96.133.171","userAgent":"73.96.133.171","referer":"http://instinct.nic.uoregon.edu:5601/app/infra"},"res":{"statusCode":500,"responseTime":135,"contentLength":9},"message":"POST /api/metrics/snapshot 500 135ms - 9.0B"}

```

Any ideas why I am seeing this only on the Metrics page? There are no metrics being shipped, but I imagine that should not be a reason for an ISE 500. Kibana is otherwise working as I would expect. I am new to ELK so totally possible I am doing something dumb.

---

<div class="post-metadata">

**Author:** ![weltenwort](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/weltenwort/32/53885_2.png) [@weltenwort](https://discuss.elastic.co/u/weltenwort)\
**Post date:** [March 30, 2020, 9:25am UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/2 "2020-03-30T09:25:38Z")

</div>

Hi @eugeneswalker,

thanks for sharing the detailed error messages. I suspect the underlying reason should be shown in the Kibana server log. What you posted as the server log looks like reverse proxy's access log. Can you get at the log output of the Kibana server process somehow?

---

<div class="post-metadata">

**Author:** ![trajano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/trajano/32/38853_2.png) [@trajano](https://discuss.elastic.co/u/trajano)\
**Post date:** [April 20, 2020, 7:50pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/3 "2020-04-20T19:50:08Z")

</div>

I have the exact same error, I'll try to do what you had which was using 7.6.1 to see if it will start working again. In my case I am running behind a proxy so I set the following environment variables

```auto
- "SERVER_BASEPATH=/kibana"
- "SERVER_REWRITEBASEPATH=true"
- "LOGGING_SILENT=true"

```

Unfortunately 7.6.1 didn't help either. BTW I didn't get anything on the logs that appear relevant even with `LOGGING_SILENT` not set

What worked in the end was downgrading Kibana to 7.5.2

---

<div class="post-metadata">

**Author:** ![Ivan\_A\_Carrazana\_C](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ivan_a_carrazana_c/32/67121_2.png) [@Ivan\_A\_Carrazana\_C](https://discuss.elastic.co/u/Ivan_A_Carrazana_C)\
**Post date:** [April 25, 2020, 6:50pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/4 "2020-04-25T18:50:34Z")

</div>

Hi, I have had the same problem for two weeks. Every time I wanted to see the metrics of a specific host, it returned an error 500.

Today I solved it by configuring apm-server, enabling it in kibana (I had disabled it because I thought I would not use it) and allowing auto-creation of the apm- \* index in elasticsearch.

Now I can see the metric detail for each node.

If you need I can share my elasticsearch conf, kibana, metricbeat and apm-server.

---

<div class="post-metadata">

**Author:** ![bard0x](https://avatars.discourse-cdn.com/v4/letter/b/5fc32e/32.png) [@bard0x](https://discuss.elastic.co/u/bard0x)\
**Post date:** [May 5, 2020, 12:44pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/5 "2020-05-05T12:44:27Z")

</div>

Can you share the config files please? Thank's

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 2, 2020, 12:44pm UTC](https://discuss.elastic.co/t/viewing-metrics-500-internal-server-error/225501/6 "2020-06-02T12:44:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
