# Visualization / Dashboard error: Saved "field" parameter is now invalid

**URL:** <https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934>\
**Category:** Kibana\
**Created:** [December 16, 2019, 1:01am UTC](https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934 "2019-12-16T01:01:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Camilo\_Diaz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/camilo_diaz/32/46512_2.png) [@Camilo\_Diaz](https://discuss.elastic.co/u/Camilo_Diaz)\
**Post date:** [December 16, 2019, 1:01am UTC](https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934/1 "2019-12-16T01:01:59Z")

</div>

I have a clean install of Elastic stack + Filebeat

Filetbeats 7.5 --\> Logstash --\> Elasticsearch 7.5

From Filebeats client I have loaded the Suricata Module and have manually loaded the ingest pipelines (all completed without errors)

> filebeat setup --pipelines --modules suricata  
> filebeat setup --dashboard

I can visualize data on the discovery tab but when I open any Suricata Visualization or Dashboard I've got the following error.  
"Saved "field" parameter is now invalid. Please select a new field."

 ![Kibana_Visualization](https://us1.discourse-cdn.com/elastic/original/3X/3/6/36bc5678a56983323a44ff98b1a5c1bc47c8fa69.png)

I can't find anything in the kibana/Elasticsearch logs, as to what is wrong. Any help will be much appreciatted. I had the exactly same problem using haproxy modules and dashboards and i've recreated the indexes and reloaded the modules/dashboard several times and kept having the same issues.

---

<div class="post-metadata">

**Author:** ![Camilo\_Diaz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/camilo_diaz/32/46512_2.png) [@Camilo\_Diaz](https://discuss.elastic.co/u/Camilo_Diaz)\
**Post date:** [December 16, 2019, 8:03pm UTC](https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934/2 "2019-12-16T20:03:43Z")

</div>

ok so it looks the problem are the visualizations, so I'll have to manually modify them to match the keyword value. It would be nice that these dashboards worked out the box. This can be closed/resolved.  
This seems to have been happening for a while in kibana, as per [https://github.com/elastic/kibana/issues/9571](https://github.com/elastic/kibana/issues/9571)  
Cheers,  
Camilo.

---

<div class="post-metadata">

**Author:** ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)\
**Post date:** [December 17, 2019, 6:53pm UTC](https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934/3 "2019-12-17T18:53:32Z")

</div>

@Camilo_Diaz there might be an issue with the mappings template or the index pattern beats is auto creating for this module, would you mind filing an issue on the Beats Github repo?

> **[Build software better, together](https://github.com/elastic/beats/issues/new?template=bug-report.md)**
>
> GitHub is where people build software. More than 40 million people use GitHub to discover, fork, and contribute to over 100 million projects.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2020, 6:53pm UTC](https://discuss.elastic.co/t/visualization-dashboard-error-saved-field-parameter-is-now-invalid/211934/4 "2020-01-14T18:53:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
