# Visualize: "field" is a required parameter - ELK 5.5.2

**URL:** https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334
**Category:** Kibana
**Created:** [September 4, 2017, 4:36pm UTC](https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334 "2017-09-04T16:36:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![TomD](https://avatars.discourse-cdn.com/v4/letter/t/b4bc9f/32.png) [@TomD](https://discuss.elastic.co/u/TomD)
#### Post date: [September 4, 2017, 4:36pm UTC](https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334/1 "2017-09-04T16:36:45Z")

</div>

Hi

I moved my elasticsearch, logstash, and kibana to a RHEL 7.4 box from a 6.9 and now I see the below errors on any of the sample dashboards. I am only using metricbeat and it's sample dashboards. An identical setup worked on RHEL 6.9. Please help!

TypeError: "field" is a required parameter  
at FieldAggParam.AggTypesParamTypesFieldProvider.FieldAggParam.write ([http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:10484](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:10484))  
at [http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:8083](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:8083)  
at AggParams.forEach ()  
at AggParams.AggTypesAggParamsProvider.AggParams.write ([http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:8041](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:120:8041))  
at AggConfig.VisAggConfigProvider.AggConfig.write ([http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:121:23157](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:121:23157))  
at AggConfig.VisAggConfigProvider.AggConfig.toDsl ([http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:121:23986](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:121:23986))  
at [http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:2011](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:2011)  
at Array.forEach ()  
at AggConfigs.VisAggConfigsProvider.AggConfigs.toDsl ([http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:1794](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:1794))  
at [http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:31216](http://lhcvccstst02:5601/bundles/kibana.bundle.js?v=15443:137:31216)

---

<div class="post-metadata">

### Author: ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)
#### Post date: [September 4, 2017, 5:39pm UTC](https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334/2 "2017-09-04T17:39:34Z")

</div>

There is a work around for the issue that you're experiencing. You can find it here:

> [@Invalid Parameter "field"](https://discuss.elastic.co/t/invalid-parameter-field/89637/2):
>
> Looks like you're hitting this issue; To resolve this, you should click that pencil icon in your Traffic Over Time visualization to get to the visualization editor. Then check the fields used in the visualization. The error seems to be caused by a field in the visualization that isn't in the docs, or that isn't aggregatable. In my case, I found that earlier versions of Kibana allowed you to use fields which were not aggregatable in a visualization, but now that causes the error you are s…

---

<div class="post-metadata">

### Author: ![TomD](https://avatars.discourse-cdn.com/v4/letter/t/b4bc9f/32.png) [@TomD](https://discuss.elastic.co/u/TomD)
#### Post date: [September 4, 2017, 8:43pm UTC](https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334/3 "2017-09-04T20:43:16Z")

</div>

Hi

Thank you for your reply! I don't see a Traffic Over Time visualisation but I see the same error when I use the metric beat System overview by host dashboard. I click edit and see no errors

 ![11](https://us1.discourse-cdn.com/elastic/original/3X/8/4/84f887e532aa976622a89761685c3e022dfbdf3a.png)

Here is the expanded error

 ![57](https://us1.discourse-cdn.com/elastic/original/3X/e/f/ef46b94f97ff82a4103dfb5191763af8b92bbe4f.png)

Here is the exported JSON

[  
{  
"\_id": "System-overview-by-host",  
"\_type": "visualization",  
"\_source": {  
"description": "",  
"kibanaSavedObjectMeta": {  
"searchSourceJSON": "{"filter":}"  
},  
"savedSearchId": "System-stats",  
"title": "System overview by host",  
"uiStateJSON": "{"vis":{"params":{"sort":{"columnIndex":null,"direction":null}}}}",  
"version": 1,  
"visState": "{"title":"System overview by host","type":"table","params":{"perPage":10,"showPartialRows":false,"showMeticsAtAllLevels":false,"sort":{"columnIndex":null,"direction":null},"showTotal":false,"totalFunc":"sum"},"aggs":[{"id":"1","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.memory.used.pct","customLabel":"Used memory"}},{"id":"2","enabled":true,"type":"terms","schema":"bucket","params":{"field":"beat.name","size":50,"order":"desc","orderBy":"\_term","customLabel":"Host"}},{"id":"8","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.memory.total","customLabel":"Total memory"}},{"id":"3","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.fsstat.total\_size.used","customLabel":"Used disk space"}},{"id":"4","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.load.norm.1","customLabel":"System load / cores"}},{"id":"5","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.cpu.user.pct","customLabel":"CPU usage"}},{"id":"6","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.network.in.dropped","customLabel":"In dropped"}},{"id":"7","enabled":true,"type":"avg","schema":"metric","params":{"field":"system.network.out.dropped","customLabel":"Out dropped"}}],"listeners":{}}"  
}  
}  
]

Thank you  
Tom

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 2, 2017, 8:43pm UTC](https://discuss.elastic.co/t/visualize-field-is-a-required-parameter-elk-5-5-2/99334/4 "2017-10-02T20:43:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
