# \[warning\]\[migrations\] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

**URL:** <https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472>\
**Category:** Kibana\
**Created:** [January 17, 2020, 1:52pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472 "2020-01-17T13:52:16Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![mparp](https://avatars.discourse-cdn.com/v4/letter/m/cdc98d/32.png) [@mparp](https://discuss.elastic.co/u/mparp)\
**Post date:** [January 17, 2020, 1:52pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/1 "2020-01-17T13:52:16Z")

</div>

Hi all!

Can you please help me to solve the problem with Kibana.

I installed latest version of Elasticsearch and Kibana on the same server with minimum configuration. Installation is standalone. Server IP address 192.168.171.3

**Elastic config:**

* * *

cluster.name: eleks-cluster  
node.name: elks-1  
path.logs: E:\Elastic\ElasticLOGS  
network.host: 192.168.171.3  
discovery.seed\_hosts: ["192.168.171.3"]  
xpack.security.enabled: false

* * *

**Kibana config:**

* * *

server.host: "192.168.171.3"  
server.name: "kibana-elks1"  
elasticsearch.hosts: ["[http://192.168.171.3:9200](http://192.168.171.3:9200)"]

**HTTP response from Elasticserach:**

{  
"name" : "elks-1",  
"cluster\_name" : "eleks-cluster",  
"cluster\_uuid" : "_na_",  
"version" : {  
"number" : "7.5.1",  
"build\_flavor" : "default",  
"build\_type" : "zip",  
"build\_hash" : "3ae9ac9a93c95bd0cdc054951cf95d88e1e18d96",  
"build\_date" : "2019-12-16T22:57:37.835892Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.3.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

Error from Kibana:  
PS E:\Elastic\kibana-7.5.1-windows-x86\_64\kibana-7.5.1-windows-x86\_64\bin\> .\kibana.bat  
log [12:49:01.674] [info][plugins-service] Plugin "security" is disabled.  
log [12:49:01.759] [info][plugins-system] Setting up [14] plugins: [licensing,code,timelion,features,spaces,translations,uiActions,newsfeed,expressions,inspector,embeddable,advancedUiActions,eui\_utils,data]  
log [12:49:01.761] [info][licensing][plugins] Setting up plugin  
log [12:49:01.765] [info][code][plugins] Setting up plugin  
log [12:49:01.766] [info][plugins][timelion] Setting up plugin  
log [12:49:01.768] [info][features][plugins] Setting up plugin  
log [12:49:01.769] [info][plugins][spaces] Setting up plugin  
log [12:49:01.776] [info][plugins][translations] Setting up plugin  
log [12:49:01.777] [info][data][plugins] Setting up plugin  
log [12:49:08.248] [warning][licensing][plugins] License information could not be obtained from Elasticsearch for the [data] cluster. TypeError: Cannot use 'in' operator to search for 'type' in null  
log [12:49:08.658] [warning][legacy-plugins] Skipping non-plugin directory at E:\Elastic\kibana-7.5.1-windows-x86\_64\kibana-7.5.1-windows-x86\_64\src\legacy\core\_plugins\visualizations  
log [12:49:09.693] [info][plugins-system] Starting [7] plugins: [licensing,code,timelion,features,spaces,translations,data]  
log [12:49:31.848] [warning][licensing][plugins] License information could not be obtained from Elasticsearch for the [data] cluster. TypeError: Cannot use 'in' operator to search for 'type' in null  
log [12:49:39.704] [warning][migrations] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms  
log [12:50:01.875] [warning][licensing][plugins] License information could not be obtained from Elasticsearch for the [data] cluster. TypeError: Cannot use 'in' operator to search for 'type' in null

As i suggest the primary error is:  
[warning][migrations] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

Any ideas?  
Thank you!

---

<div class="post-metadata">

**Author:** ![matw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matw/32/13913_2.png) [@matw](https://discuss.elastic.co/u/matw)\
**Post date:** [January 17, 2020, 6:02pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/2 "2020-01-17T18:02:46Z")

</div>

Hi

Can you try if Elasticsearch also returns this response if you try this request directly on server via curl?

Thx & Best,  
Matthias

---

<div class="post-metadata">

**Author:** ![mparp](https://avatars.discourse-cdn.com/v4/letter/m/cdc98d/32.png) [@mparp](https://discuss.elastic.co/u/mparp)\
**Post date:** [January 20, 2020, 5:13pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/3 "2020-01-20T17:13:27Z")

</div>

> [@mparp](#):
>
> "[http://192.168.171.3:9200](http://192.168.171.3:9200)"]

Hi.

CURL response:

curl.exe [http://192.168.171.3:9200](http://192.168.171.3:9200)

{  
"name" : "elks-1",  
"cluster\_name" : "eleks-cluster",  
"cluster\_uuid" : "7F7AnlnuRsShGT9W\_yOIGw",  
"version" : {  
"number" : "7.5.1",  
"build\_flavor" : "default",  
"build\_type" : "zip",  
"build\_hash" : "3ae9ac9a93c95bd0cdc054951cf95d88e1e18d96",  
"build\_date" : "2019-12-16T22:57:37.835892Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.3.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

What is strange. Kibana started, but first of it is extremely slow and during startup of kibana I see a lot of errors and warnings.

Looks like I am messing something :(!

Kibana startup:

E:\Elastic\kibana-7.5.1-windows-x86\_64\kibana-7.5.1-windows-x86\_64\bin\> .\kibana.bat  
og [17:06:39.371] [info][plugins-service] Plugin "security" is disabled.  
og [17:06:39.588] [info][plugins-system] Setting up [14] plugins: [code,timelion,features,licensing,spaces,newsfeed  
Actions,eui\_utils,inspector,embeddable,advancedUiActions,expressions,translations,data]  
og [17:06:39.592] [info][code][plugins] Setting up plugin  
og [17:06:39.594] [info][plugins][timelion] Setting up plugin  
og [17:06:39.597] [info][features][plugins] Setting up plugin  
og [17:06:39.599] [info][licensing][plugins] Setting up plugin  
og [17:06:39.604] [info][plugins][spaces] Setting up plugin  
og [17:06:39.614] [info][plugins][translations] Setting up plugin  
og [17:06:39.624] [info][data][plugins] Setting up plugin  
og [17:07:25.429] [warning][licensing][plugins] License information could not be obtained from Elasticsearch for th  
data] cluster. Error: Request Timeout after 20000ms  
og [17:07:28.185] [warning][legacy-plugins] Skipping non-plugin directory at E:\Elastic\kibana-7.5.1-windows-x86\_64  
bana-7.5.1-windows-x86\_64\src\legacy\core\_plugins\visualizations  
og [17:07:30.754] [info][licensing][plugins] Imported changed license information from Elasticsearch for the [data]  
uster: type: basic | status: active  
og [17:07:32.027] [info][plugins-system] Starting [7] plugins: [code,timelion,features,licensing,spaces,translation  
ata]  
og [17:07:52.991] [info][status][plugin:kibana@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:52.997] [info][status][plugin:elasticsearch@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.000] [info][status][plugin:xpack\_main@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.011] [info][status][plugin:graph@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.025] [info][status][plugin:monitoring@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.032] [info][status][plugin:spaces@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.034] [info][status][plugin:searchprofiler@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.037] [info][status][plugin:ml@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.108] [info][status][plugin:tilemap@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.111] [info][status][plugin:watcher@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.128] [info][status][plugin:grokdebugger@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.130] [info][status][plugin:dashboard\_mode@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.132] [info][status][plugin:logstash@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.140] [info][status][plugin:beats\_management@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.162] [info][status][plugin:apm\_oss@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.210] [info][status][plugin:apm@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.215] [info][status][plugin:interpreter@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.217] [info][status][plugin:expressions@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.222] [info][status][plugin:maps@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.243] [info][status][plugin:canvas@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.249] [info][status][plugin:license\_management@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.252] [info][status][plugin:cloud@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.254] [info][status][plugin:index\_management@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.271] [info][status][plugin:console@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.273] [info][status][plugin:console\_extensions@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.276] [info][status][plugin:index\_lifecycle\_management@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.286] [info][status][plugin:kuery\_autocomplete@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.291] [info][status][plugin:metrics@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.343] [info][status][plugin:infra@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.348] [info][task\_manager] Initialising Task Manager with UUID: 270b49e0-b97a-49ec-a282-d3679c690c45  
og [17:07:53.349] [info][status][plugin:task\_manager@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.352] [info][status][plugin:rollup@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.373] [info][status][plugin:transform@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.376] [info][siem] Plugin initializing  
og [17:07:53.416] [info][siem] Plugin done initializing  
og [17:07:53.422] [info][status][plugin:siem@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.429] [info][status][plugin:remote\_clusters@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.433] [info][status][plugin:cross\_cluster\_replication@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.465] [info][status][plugin:upgrade\_assistant@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.497] [info][status][plugin:uptime@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.502] [info][status][plugin:oss\_telemetry@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.506] [info][status][plugin:file\_upload@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.512] [warning][encrypted\_saved\_objects] Generating a random key for xpack.encrypted\_saved\_objects.encryptionKey. To be able to decrypt encrypted saved objects attributes after restart, please set xpack.encrypted\_saved\_objects.encryptionKey in kibana.yml  
og [17:07:53.514] [info][status][plugin:encrypted\_saved\_objects@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.517] [info][status][plugin:data@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.527] [info][status][plugin:lens@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.558] [info][status][plugin:snapshot\_restore@7.5.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
og [17:07:53.576] [info][status][plugin:kibana\_react@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.584] [info][status][plugin:region\_map@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.591] [info][status][plugin:navigation@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.602] [info][status][plugin:markdown\_vis@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.611] [info][status][plugin:telemetry@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.617] [info][status][plugin:metric\_vis@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.620] [info][status][plugin:table\_vis@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.624] [info][status][plugin:tagcloud@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:53.632] [info][status][plugin:vega@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:54.675] [info][status][plugin:timelion@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:54.685] [info][status][plugin:ui\_metric@7.5.1] Status changed from uninitialized to green - Ready  
og [17:07:58.814] [info][status][plugin:elasticsearch@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.901] [info][license][xpack] Imported license information from Elasticsearch for the [data] cluster: mode: basic | status: active  
og [17:07:58.922] [info][status][plugin:xpack\_main@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.925] [info][status][plugin:graph@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.930] [info][status][plugin:searchprofiler@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.934] [info][status][plugin:ml@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.936] [info][status][plugin:tilemap@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.938] [info][status][plugin:watcher@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.944] [info][status][plugin:grokdebugger@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.946] [info][status][plugin:logstash@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.948] [info][status][plugin:beats\_management@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.951] [info][status][plugin:index\_management@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.953] [info][status][plugin:index\_lifecycle\_management@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.961] [info][status][plugin:rollup@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.984] [info][status][plugin:transform@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.989] [info][status][plugin:remote\_clusters@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.992] [info][status][plugin:cross\_cluster\_replication@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.996] [info][status][plugin:file\_upload@7.5.1] Status changed from yellow to green - Ready  
og [17:07:58.998] [info][status][plugin:snapshot\_restore@7.5.1] Status changed from yellow to green - Ready  
og [17:07:59.000] [info][kibana-monitoring][monitoring] Starting monitoring stats collection  
og [17:07:59.026] [info][status][plugin:maps@7.5.1] Status changed from yellow to green - Ready  
og [17:07:59.057] [info][status][plugin:spaces@7.5.1] Status changed from yellow to green - Ready  
og [17:08:00.017] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml  
og [17:08:00.023] [info][status][plugin:reporting@7.5.1] Status changed from uninitialized to green - Ready  
og [17:08:00.090] [info][listening] Server running at [http://192.168.171.3:5601](http://192.168.171.3:5601)  
og [17:08:00.127] [info][server][Kibana][http] http server running at [http://192.168.171.3:5601](http://192.168.171.3:5601)

---

<div class="post-metadata">

**Author:** ![mparp](https://avatars.discourse-cdn.com/v4/letter/m/cdc98d/32.png) [@mparp](https://discuss.elastic.co/u/mparp)\
**Post date:** [January 20, 2020, 8:54pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/4 "2020-01-20T20:54:12Z")

</div>

I did a little research. I installed OSS version of Kibana (kibana-oss-7.5.1-windows) and it works.

Know I have other questions:

1. I can use normal kibana? Only restricted version?
2. Why elastic has so strong limitations? Even Kibana dashboard is limited:  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/4/2422dd80c95b213bdc1de5820188494821d12179.png)
3. is any way to use normal kibana even with license restrictions?  
Regards,  
Max

---

<div class="post-metadata">

**Author:** ![matw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matw/32/13913_2.png) [@matw](https://discuss.elastic.co/u/matw)\
**Post date:** [January 21, 2020, 4:49am UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/5 "2020-01-21T04:49:26Z")

</div>

1. so you managed to make the licensed kibana to connect to elasticsearch? but what was slow? the start up process?
2. OSS version is limited, license basic adds more features, while still free. licenses are necessary because of business developments
3. It should, since it works with OSS, I can't see a reason, why it shouldn't work with the licensed version

best,  
Matthias

---

<div class="post-metadata">

**Author:** ![mparp](https://avatars.discourse-cdn.com/v4/letter/m/cdc98d/32.png) [@mparp](https://discuss.elastic.co/u/mparp)\
**Post date:** [January 27, 2020, 4:50pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/6 "2020-01-27T16:50:52Z")

</div>

Hi Matthias,  
When I run kibana.bat It takes about two minutes to start the process. The problem is that in automatic mode (through the create Windows service) the service does not start due to a timeout. I solved the problem by changing the registry value for ServicesPipeTimeout. But it is uncomfortable to know that something does not work without advanced configuration.  
The same problem for logstash, it will not run from "Windows service automatic start" because of timeout error.

![image](https://us1.discourse-cdn.com/elastic/original/3X/6/0/6019bfd51eb25bb63db3cd768aceb8f3bc007064.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 24, 2020, 4:50pm UTC](https://discuss.elastic.co/t/warning-migrations-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/215472/7 "2020-02-24T16:50:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
