# Warning savedobjects-service Unable to connect to Elasticsearch Error Request Timeout after 30000ms

**URL:** <https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029>\
**Category:** Kibana\
**Created:** [April 15, 2020, 4:28am UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029 "2020-04-15T04:28:45Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![vivek898](https://avatars.discourse-cdn.com/v4/letter/v/bc8723/32.png) [@vivek898](https://discuss.elastic.co/u/vivek898)\
**Post date:** [April 15, 2020, 4:28am UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/1 "2020-04-15T04:28:45Z")

</div>

New to ELK and setting up in rhel 7.5 OS. Kibana is throwing error while setting up on master.

Deleted below indices and tried again, but same error.

red open .kibana\_task\_manager\_1 jmlrFCiCT-qOt\_hsevBM1g 1 1  
red open .apm-agent-configuration ugLrtPV6QLmqXwkWXF9oMw 1 1  
red open .kibana\_1 FbvYSkyoTO-cXVF3DUxUEQ 1 1

Elastic search  
{  
"name" : "master-1",  
"cluster\_name" : "sjc-v2",  
"cluster\_uuid" : "g-MOWUQGQMmgOUaCP0cdYA",  
"version" : {  
"number" : "7.6.2",  
"build\_flavor" : "default",  
"build\_type" : "tar",  
"build\_hash" : "ef48eb35cf30adf4db14086e8aabd07ef6fb113f",  
"build\_date" : "2020-03-26T06:34:37.794943Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.4.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

Kibana logs

log [03:46:58.923] [info][plugins-service] Plugin "case" is disabled.  
log [03:47:03.170] [info][plugins-system] Setting up [37] plugins: [taskManager,siem,licensing,infra,encryptedSavedObjects,code,usageCollection,metrics,canvas,timelion,features,security,apm\_oss,translations,reporting,uiActions,data,navigation,status\_page,share,newsfeed,kibana\_legacy,management,dev\_tools,inspector,expressions,visualizations,embeddable,advancedUiActions,dashboard\_embeddable\_container,home,spaces,cloud,apm,graph,eui\_utils,bfetch]  
log [03:47:03.172] [info][plugins][taskManager] Setting up plugin  
log [03:47:03.187] [info][plugins][siem] Setting up plugin  
log [03:47:03.188] [info][licensing][plugins] Setting up plugin  
log [03:47:03.190] [info][infra][plugins] Setting up plugin  
log [03:47:03.191] [info][encryptedSavedObjects][plugins] Setting up plugin  
log [03:47:03.192] [warning][config][encryptedSavedObjects][plugins] Generating a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to decrypt encrypted saved objects attributes after restart, please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml  
log [03:47:03.197] [info][code][plugins] Setting up plugin  
log [03:47:03.198] [info][plugins][usageCollection] Setting up plugin  
log [03:47:03.199] [info][metrics][plugins] Setting up plugin  
log [03:47:03.200] [info][canvas][plugins] Setting up plugin  
log [03:47:03.206] [info][plugins][timelion] Setting up plugin  
log [03:47:03.207] [info][features][plugins] Setting up plugin  
log [03:47:03.208] [info][plugins][security] Setting up plugin  
log [03:47:03.209] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml  
log [03:47:03.209] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.  
log [03:47:03.228] [info][apm\_oss][plugins] Setting up plugin  
log [03:47:03.228] [info][plugins][translations] Setting up plugin  
log [03:47:03.229] [info][data][plugins] Setting up plugin  
log [03:47:03.234] [info][plugins][share] Setting up plugin  
log [03:47:03.235] [info][home][plugins] Setting up plugin  
log [03:47:03.241] [info][plugins][spaces] Setting up plugin  
log [03:47:03.246] [info][cloud][plugins] Setting up plugin  
log [03:47:03.247] [info][apm][plugins] Setting up plugin  
log [03:47:03.251] [info][graph][plugins] Setting up plugin  
log [03:47:03.253] [info][bfetch][plugins] Setting up plugin  
log [03:47:03.259] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...  
log [03:47:03.301] [info][savedobjects-service] Starting saved objects migrations  
log [03:47:03.312] [info][savedobjects-service] Creating index .kibana\_task\_manager\_1.  
log [03:47:03.316] [info][savedobjects-service] Creating index .kibana\_1.  
Could not create APM Agent configuration: Request Timeout after 30000ms  
log [03:47:33.313] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms  
log [03:47:35.817] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource\_already\_exists\_exception] index [.kibana\_task\_manager\_1/6jHlllmtTmGSJI3vco\_KJw] already exists, with { index\_uuid="6jHlllmtTmGSJI3vco\_KJw" & index=".kibana\_task\_manager\_1" }  
log [03:47:35.818] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana\_task\_manager\_1 and restarting Kibana.  
log [03:47:35.828] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource\_already\_exists\_exception] index [.kibana\_1/xvwnY15cQaStFRV-qjMbaA] already exists, with { index\_uuid="xvwnY15cQaStFRV-qjMbaA" & index=".kibana\_1" }  
log [03:47:35.829] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana\_1 and restarting Kibana.

---

<div class="post-metadata">

**Author:** ![vivek898](https://avatars.discourse-cdn.com/v4/letter/v/bc8723/32.png) [@vivek898](https://discuss.elastic.co/u/vivek898)\
**Post date:** [April 15, 2020, 4:31am UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/2 "2020-04-15T04:31:47Z")

</div>

Kibana config

server.port: 80  
server.host: "10.120.0.51"

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [April 15, 2020, 2:23pm UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/3 "2020-04-15T14:23:24Z")

</div>

It looks like you already have an ES running. is that running from master as well and is it a clean version?  
The best guide to running Kibana from master is here: [https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md](https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md)

---

<div class="post-metadata">

**Author:** ![vivek898](https://avatars.discourse-cdn.com/v4/letter/v/bc8723/32.png) [@vivek898](https://discuss.elastic.co/u/vivek898)\
**Post date:** [April 15, 2020, 4:45pm UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/4 "2020-04-15T16:45:55Z")

</div>

Yes, its a fresh installation both elasticsearch and kibana, downloaded in a week. Both doesn't have any data.

---

<div class="post-metadata">

**Author:** ![vivek898](https://avatars.discourse-cdn.com/v4/letter/v/bc8723/32.png) [@vivek898](https://discuss.elastic.co/u/vivek898)\
**Post date:** [April 16, 2020, 3:59am UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/5 "2020-04-16T03:59:40Z")

</div>

Please close this, this was due to selinux

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 14, 2020, 3:59am UTC](https://discuss.elastic.co/t/warning-savedobjects-service-unable-to-connect-to-elasticsearch-error-request-timeout-after-30000ms/228029/6 "2020-05-14T03:59:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
