# Was the icu\_tokenizer renamed?

**URL:** <https://discuss.elastic.co/t/was-the-icu-tokenizer-renamed/231798>\
**Category:** Elasticsearch\
**Created:** [May 8, 2020, 8:33pm UTC](https://discuss.elastic.co/t/was-the-icu-tokenizer-renamed/231798 "2020-05-08T20:33:49Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pushshift](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pushshift/32/50408_2.png) [@pushshift](https://discuss.elastic.co/u/pushshift)\
**Post date:** [May 8, 2020, 8:33pm UTC](https://discuss.elastic.co/t/was-the-icu-tokenizer-renamed/231798/1 "2020-05-08T20:33:49Z")

</div>

I'm getting the following error after performing: (I have installed the analyzer-icu plugin under ES 7.6.x)

curl -H "content-type: application/json" -XPUT localhost:9200/icu\_sample -d @icu\_tokenizer

icu\_tokenizer file:

```
{
  "settings": {
    "index": {
      "analysis": {
        "analyzer": {
          "my_icu_analyzer": {
            "tokenizer": "icu_tokenizer"
          }
        }
      }
    }
  }
}

```

Error:

`{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Custom Analyzer [my_icu_analyzer] failed to find tokenizer under name [icu_tokenizer]"}],"type":"illegal_argument_exception","reason":"Custom Analyzer [my_icu_analyzer] failed to find tokenizer under name [icu_tokenizer]"},"status":400}`

---

<div class="post-metadata">

**Author:** ![pushshift](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pushshift/32/50408_2.png) [@pushshift](https://discuss.elastic.co/u/pushshift)\
**Post date:** [May 8, 2020, 8:40pm UTC](https://discuss.elastic.co/t/was-the-icu-tokenizer-renamed/231798/2 "2020-05-08T20:40:25Z")

</div>

My apologies -- Another case of RTFM.

I needed to also restart all nodes in the cluster. It's working now. For those who might encounter issues, these are the steps you need to follow:

1. Install the ICU Analyzer plugin on every node in the cluster. For my Ubuntu Server, this was the command to do it:

`/usr/share/elasticsearch/bin/elasticsearch-plugin install analysis-icu`

1. Restart the elasticsearch service for every node in the cluster:

`systemctl restart elasticsearch`

You need to make sure each node has the plug-in installed and that each node is then restarted. Hope this helps someone in the future.

As a side note: If you upgrade your version of Elasticsearch on nodes in the cluster, you will need to REMOVE and then INSTALL the icu-analysis plugin. If you fail to remove and re-install the plug-in after updating your nodes, the nodes will fail to reboot until the plug-in is also updated.

As always, RTFM! 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 5, 2020, 8:40pm UTC](https://discuss.elastic.co/t/was-the-icu-tokenizer-renamed/231798/3 "2020-06-05T20:40:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
