# Watcher Email Configuration error

**URL:** <https://discuss.elastic.co/t/watcher-email-configuration-error/33127>\
**Category:** Elasticsearch\
**Created:** [October 28, 2015, 7:26am UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127 "2015-10-28T07:26:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![krish0608](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krish0608/32/6797_2.png) [@krish0608](https://discuss.elastic.co/u/krish0608)\
**Post date:** [October 28, 2015, 7:26am UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127/1 "2015-10-28T07:26:41Z")

</div>

Hi,

I have configured watcher to Elasticsearch to get Alert & Notifications and I have setup Email configuration in yml file as shown below.

watcher.actions.email.service.account:  
work:  
profile: gmail  
smtp:  
auth: true  
starttls.enable: true  
host: [krishna.kumar0608@gmail.com](mailto:krishna.kumar0608@gmail.com)  
port: 587  
user: [krishna.kumar0608@gmail.com](mailto:krishna.kumar0608@gmail.com)  
password: password

But I am getting error as,

./elasticsearch  
{1.7.1}: Setup Failed ...

- SettingsException[Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]]  
IOException[Tabs are illegal in YAML. Did you mean to use whitespace character instead?]  
org.elasticsearch.common.settings.SettingsException: Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:985)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)  
at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)  
at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)  
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)  
Caused by: java.io.IOException: Tabs are illegal in YAML. Did you mean to use whitespace character instead?  
at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:44)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)  
... 5 more

root@krishna-Vostro-1015:/home/krishna/Downloads/elasticsearch-1.7.1/bin# ./elasticsearch  
{1.7.1}: Setup Failed ...

- SettingsException[Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]]  
IOException[Tabs are illegal in YAML. Did you mean to use whitespace character instead?]  
org.elasticsearch.common.settings.SettingsException: Failed to load settings from [file:/home/krishna/Downloads/elasticsearch-1.7.1/config/elasticsearch.yml]  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:985)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)  
at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)  
at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)  
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)  
Caused by: java.io.IOException: Tabs are illegal in YAML. Did you mean to use whitespace character instead?  
at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:44)  
at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)  
... 5 more

please help me out.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 28, 2015, 7:35am UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127/2 "2015-10-28T07:35:45Z")

</div>

> [@krish0608](#):
>
> Tabs are illegal in YAML. Did you mean to use whitespace character instead?

This is why, do you have tabs?

---

<div class="post-metadata">

**Author:** ![krish0608](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krish0608/32/6797_2.png) [@krish0608](https://discuss.elastic.co/u/krish0608)\
**Post date:** [October 28, 2015, 7:36am UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127/3 "2015-10-28T07:36:47Z")

</div>

No,i dont think so..!!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 28, 2015, 8:08am UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127/4 "2015-10-28T08:08:09Z")

</div>

But elasticsearch thinks you do. 😛

I'd trust elasticsearch and double check.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:42pm UTC](https://discuss.elastic.co/t/watcher-email-configuration-error/33127/5 "2017-07-05T23:42:14Z")

</div>


