# Watcher email configuration

**URL:** <https://discuss.elastic.co/t/watcher-email-configuration/208356>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [November 18, 2019, 5:06pm UTC](https://discuss.elastic.co/t/watcher-email-configuration/208356 "2019-11-18T17:06:08Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [November 21, 2019, 12:08pm UTC](https://discuss.elastic.co/t/watcher-email-configuration/208356/2 "2019-11-21T12:08:55Z")

</div>

So, there are two different exceptions

> Couldn't connect to host, port: [smtp.gmail.com](http://smtp.gmail.com), 587; timeout 120000

This one means, that it could connect to gmail, but was not able to send an email within 2 minutes (which is a long time)

> _Caused by: javax.mail.AuthenticationFailedException: **failed to connect, no password specified?** _

This one means that the user/password could not be successfully authenticated.

I have a hard time spotting the differences between the two setups, maybe you can explain this. Also make sure that after changing a keystore you either restart the node or reload secure settings. And make sure that setting is on every keystore on each node in the cluster (and reloaded), before trying further.

---

_[View the full topic](https://discuss.elastic.co/t/watcher-email-configuration/208356)._
