# Watcher error message - filesystem ran out of space and can't recover

**URL:** <https://discuss.elastic.co/t/watcher-error-message-filesystem-ran-out-of-space-and-cant-recover/26978>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-alerting\
**Created:** [August 6, 2015, 2:55pm UTC](https://discuss.elastic.co/t/watcher-error-message-filesystem-ran-out-of-space-and-cant-recover/26978 "2015-08-06T14:55:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![dmccuk](https://avatars.discourse-cdn.com/v4/letter/d/3d9bf3/32.png) [@dmccuk](https://discuss.elastic.co/u/dmccuk)\
**Post date:** [August 6, 2015, 2:55pm UTC](https://discuss.elastic.co/t/watcher-error-message-filesystem-ran-out-of-space-and-cant-recover/26978/1 "2015-08-06T14:55:01Z")

</div>

Hi,

My filesystem ran out of space due to elasticsearch indexes (my fault). Elasticsearch is back up again but I can't do anything with watcher anymore. I get this error in the logs:

```
[2015-08-06 15:50:58,112][WARN][index.engine] [Contrary] [.triggered_watches][0] failed to sync translog
[2015-08-06 15:50:58,112][WARN][indices.cluster] [Contrary] [[.triggered_watches][0]] marking and sending shard failed due to [failed recovery]
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [.triggered_watches][0] failed to recover shard
        at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:297)
        at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:112)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.elasticsearch.index.translog.TranslogCorruptedException: translog corruption while reading from stream
        at org.elasticsearch.index.translog.ChecksummedTranslogStream.read(ChecksummedTranslogStream.java:72)
        at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:267)
        ... 4 more
Caused by: org.elasticsearch.ElasticsearchIllegalArgumentException: No version type match [78]
        at org.elasticsearch.index.VersionType.fromValue(VersionType.java:307)
        at org.elasticsearch.index.translog.Translog$Create.readFrom(Translog.java:376)
        at org.elasticsearch.index.translog.ChecksummedTranslogStream.read(ChecksummedTranslogStream.java:68)
        ... 5 more
[2015-08-06 15:50:58,112][WARN][cluster.action.shard] [Contrary] [.triggered_watches][0] received shard failed for [.triggered_watches][0], node[U-KtH2Y1TsCMC9Lp_503lA], [P], s[INITIALIZING], indexUUID [s7VKq9ThTvu5CIhjIrftxw], reason [shard failure [failed recovery][IndexShardGatewayRecoveryException[[.triggered_watches][0] failed to recover shard]; nested: TranslogCorruptedException[translog corruption while reading from stream]; nested: ElasticsearchIllegalArgumentException[No version type match [78]]; ]]

```

Does anyone have any helpful tips to get it back up and working before i re-install ES and watcher again.

```
red open .triggered_watches 1 1
yellow open .watches 1 1 1 2 2.8kb 2.8kb

```

Regards

Dennis

---

<div class="post-metadata">

**Author:** ![mvg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mvg/32/98890_2.png) [@mvg](https://discuss.elastic.co/u/mvg)\
**Post date:** [August 6, 2015, 3:12pm UTC](https://discuss.elastic.co/t/watcher-error-message-filesystem-ran-out-of-space-and-cant-recover/26978/2 "2015-08-06T15:12:41Z")

</div>

This is unfortunate. Best way to get Watcher operational again is to delete the `.triggered_watches` index and wait for Watcher to start automatically or start it via the start api.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:49pm UTC](https://discuss.elastic.co/t/watcher-error-message-filesystem-ran-out-of-space-and-cant-recover/26978/3 "2017-07-06T13:49:05Z")

</div>


