# Web browser high memory usage for Kibana Dashboard

**URL:** <https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992>\
**Category:** Kibana\
**Created:** [June 6, 2016, 6:54pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992 "2016-06-06T18:54:44Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![anhlqn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anhlqn/32/5454_2.png) [@anhlqn](https://discuss.elastic.co/u/anhlqn)\
**Post date:** [June 6, 2016, 6:54pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/1 "2016-06-06T18:54:44Z")

</div>

Hi All,

I use nxlog to collect Windows performance stats and store them in Elasticsearch and have a dashboard with 14 visualizations to show all different stats such as [ASP.NET](http://ASP.NET) requests, processor time, available memory, disk read/write, etc.

There are two sources of perfmon, A includes 5 servers and B includes 18 servers. Perfmon data are stored into two ES clusters on servers with lots of CPU, RAM, and SSD. The same Kibana dashboard (via export and import) for A and B are on separate Kibana instances.

My issue is when I use Google Chrome to view the dashboard

- With perfmon dashboard for A (5 servers), the Chrome tab uses around 200MB of memory.
- With perfmon dashboard for B (18 servers), the Chrome tab uses up to 1GB of memory and is usually very slow to unusable point.

When I try to open the perfmon dashboard for B in Firefox, Firefox will hang because of unresponsive script

```auto
Script: http://server:port/bundles/kibana.bundle.js?v=9689:3698

Error: [$rootScope:inprog] $digest already in progress
http://errors.angularjs.org/1.4.7/$rootScope/inprog?p0=%24digest (http://server:port/bundles/commons.bundle.js?v=9689:27679)

Version: 4.4.0
Build: 9689

Error: Error: [$rootScope:inprog] $digest already in progress
http://errors.angularjs.org/1.4.7/$rootScope/inprog?p0=%24digest (http://server:port/bundles/commons.bundle.js?v=9689:27679)
__WEBPACK_AMD_DEFINE_RESULT__ </window.onerror@http://server:port/bundles/commons.bundle.js?v=9689:63832:25

```

Perfmon index is pretty small, weekly index is about 1 GB. The number of documents retrieved from ES is about 12K for last 1 hour.

I also have big indexes ranging from 10 to 100 GB daily indexes and Kibana dashboards for them work fine on the same Kibana instance that I have trouble viewing the perfmon dashboard.

I wonder if anyone knows possible causes or ways to find out the causes of the issue.

ES: 2.2.0  
Kibaba: 4.4.0

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [June 9, 2016, 4:41pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/2 "2016-06-09T16:41:22Z")

</div>

Are you experiencing this for an auto-refreshing long-running dashboard? If so, I know there is an related open ticket: [https://github.com/elastic/kibana/issues/3188](https://github.com/elastic/kibana/issues/3188)

---

<div class="post-metadata">

**Author:** ![anhlqn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anhlqn/32/5454_2.png) [@anhlqn](https://discuss.elastic.co/u/anhlqn)\
**Post date:** [June 9, 2016, 11:30pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/3 "2016-06-09T23:30:01Z")

</div>

No, this happens right afer I open the dashboard. Have tried many times on different machines

---

<div class="post-metadata">

**Author:** ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)\
**Post date:** [June 10, 2016, 2:56am UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/4 "2016-06-10T02:56:02Z")

</div>

This certainly sounds like an issue with Kibana. Would you mind creating a ticket so you can track? [https://github.com/elastic/kibana/issues/new](https://github.com/elastic/kibana/issues/new)

Any information you could also give on the types of visualizations you have on Dashboard B would be helpful in replicating.

---

<div class="post-metadata">

**Author:** ![anhlqn](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anhlqn/32/5454_2.png) [@anhlqn](https://discuss.elastic.co/u/anhlqn)\
**Post date:** [June 10, 2016, 6:31pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/5 "2016-06-10T18:31:41Z")

</div>

Ticket created [https://github.com/elastic/kibana/issues/7427](https://github.com/elastic/kibana/issues/7427). Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:50pm UTC](https://discuss.elastic.co/t/web-browser-high-memory-usage-for-kibana-dashboard/51992/6 "2017-07-06T13:50:49Z")

</div>


