# Webhdfs Output plugin does not working with use\_kerberos\_auth

**URL:** <https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-working-with-use-kerberos-auth/322714>\
**Category:** Logstash\
**Created:** [January 9, 2023, 9:20am UTC](https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-working-with-use-kerberos-auth/322714 "2023-01-09T09:20:05Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![vincent.ea3](https://avatars.discourse-cdn.com/v4/letter/v/f0a364/32.png) [@vincent.ea3](https://discuss.elastic.co/u/vincent.ea3)\
**Post date:** [January 9, 2023, 9:20am UTC](https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-working-with-use-kerberos-auth/322714/1 "2023-01-09T09:20:05Z")

</div>

Hello,

I am working to deploy logstash in k8s container to output message to hadoop.  
[https://github.com/elastic/helm-charts](https://github.com/elastic/helm-charts)

According to the documentation, webHDFS and Kerberos authentication are supported.  
[https://www.elastic.co/guide/en/logstash/current/plugins-outputs-webhdfs.html#plugins-outputs-webhdfs-use\_kerberos\_auth](https://www.elastic.co/guide/en/logstash/current/plugins-outputs-webhdfs.html#plugins-outputs-webhdfs-use_kerberos_auth)

We try a few setups.

1. webHDFS without kerberos login -\> Success

```auto
webhdfs {
    host => "<my_hadoop>"
    port => 9780
    path => "/path/test.log"
    user => "kerberos_user"
}

```

1. webHDFS with kerberos login -\> Failed

```auto
webhdfs {
    host => "<secure_hadoop>"
    port => 9781
    path => "/path/test.log"
    user => "kerberos_user"
    kerberos_keytab => "user.keytab"
    use_kerberos_auth => "true"
}

```

We would like to highlight the error, gssapi is not included in logstash by default

```auto
Logstash stopped processing because of an error: (LoadError) no such file to load -- gssapi
org.jruby.exceptions.LoadError: (LoadError) no such file to load -- gssapi

```

There is workaround to install and copy gssapi lib to hdfs plugins  
[https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619](https://discuss.elastic.co/t/loaderror-no-such-file-to-load-gssapi/192619)

Similarly, there were login issues in 2018 from other webhdfs user and not get resolved.  
[https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-login-with-keytab/132164](https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-login-with-keytab/132164)  
[https://github.com/logstash-plugins/logstash-output-webhdfs/issues/29](https://github.com/logstash-plugins/logstash-output-webhdfs/issues/29)

Do you still support webhdfs plugin and try to fix these issues?  
Do you have a complete image / helm chart to get all plugins installed?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 6, 2023, 9:20am UTC](https://discuss.elastic.co/t/webhdfs-output-plugin-does-not-working-with-use-kerberos-auth/322714/2 "2023-02-06T09:20:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
