# Webhook - Case Management connector \`PUT\` updates fails to send \`Content-Type: application/json\` header

**URL:** <https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [March 30, 2024, 11:34pm UTC](https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492 "2024-03-30T23:34:10Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![W24800](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/w24800/32/115938_2.png) [@W24800](https://discuss.elastic.co/u/W24800)\
**Post date:** [March 30, 2024, 11:34pm UTC](https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492/1 "2024-03-30T23:34:11Z")

</div>

Elastic Version: 8.12.0

As the title states, the "Webhook - Case Management" connector `PUT` update fails to send the `Content-Type: application/json` HTTP header to case management platform. In my case, the platform is Redmine and it rejects the update due to the missing header.

The initial creation of a ticket within Redmine works fine, but errors when attempting to update the existing ticket. Error text within Kibana:

[Action][Webhook - Case Management]: Unable to update case with id 1. Error: Missing content type header in put [https://redmine.local/issues/1.json](https://redmine.local/issues/1.json). Supported content types: application/json.

---

<div class="post-metadata">

**Author:** ![W24800](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/w24800/32/115938_2.png) [@W24800](https://discuss.elastic.co/u/W24800)\
**Post date:** [March 30, 2024, 11:35pm UTC](https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492/2 "2024-03-30T23:35:21Z")

</div>

It should be noted that the Content-Type header was specified during configuration of the connector, but still only seems to be sent during initial creation.

---

<div class="post-metadata">

**Author:** ![W24800](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/w24800/32/115938_2.png) [@W24800](https://discuss.elastic.co/u/W24800)\
**Post date:** [April 2, 2024, 11:53pm UTC](https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492/3 "2024-04-02T23:53:46Z")

</div>

In testing, I reconfigured Redmine to accept the updates without the `Content-Type` header set - but Kibana still throws the same error.

When creating a new Case in this configuration, if I add Redmine as a connector when there are existing Case comments, then attempt to push the case to Redmine - the corresponding issue will be created correctly in Redmine, but the error is thrown in Kibana upon case push. This causes duplicate Redmine issues to be created each time the push is attempted.

Meanwhile, if a case is created and Redmine is added as a connector before any comments are added - the case is created successfully without error. If comments are added to the case afterward and I click `Update Redmine incident` - I will get the Kibana error but the Redmine issue is updated successfully.

There error seems to lie in Kibana identifying that it is not sending the `Content-Type` field, which is an issue within itself.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 30, 2024, 11:53pm UTC](https://discuss.elastic.co/t/webhook-case-management-connector-put-updates-fails-to-send-content-type-application-json-header/356492/4 "2024-04-30T23:53:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
