# Website down when it's public IP why?

**URL:** <https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082>\
**Category:** Beats\
**Tags:** heartbeat\
**Created:** [June 4, 2019, 3:27am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082 "2019-06-04T03:27:26Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [June 4, 2019, 3:27am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/1 "2019-06-04T03:27:27Z")

</div>

Dear all,

I just configured the heartbeat to monitor our websites， and we notice when the site is using static public IP will be reflected as "down" while the site is working fine and accessible.

IP with 202.x.x.x are not working while the rest 10.x.x.x and others are working. May I know why?

Secondly, I notice one error message on the portal saying : "dial tcp i/o timeout". Is this due to server configuration? Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 4, 2019, 4:32am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/2 "2019-06-04T04:32:33Z")

</div>

What does your config look like?

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [June 4, 2019, 5:55am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/3 "2019-06-04T05:55:45Z")

</div>

heartbeat.monitors:  
-type: http

urls:["www.......","www......"....]

schedule: '@every 10s’

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [June 4, 2019, 6:25am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/4 "2019-06-04T06:25:59Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/9/6/9601d0c2abf76a77bc9c4654a1694f2881e7dad1.png)

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/5/f57f4be89310487e09378702f99a297b5cbb78b3.png)

Under the pacemaker, I saw this error. Have anyone know how to resolve this ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 4, 2019, 7:05am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/5 "2019-06-04T07:05:06Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [June 4, 2019, 7:08am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/6 "2019-06-04T07:08:31Z")

</div>

error: unpacked\_resources: Resources start-up disabled since no STONITH resources have been defined.  
error: unpacked\_resources:Either configure or disable STONITH with the stonith-enabled option.  
error: unpacked\_resources:Note: Clusters with shared data need STONITH to ensure data integrity.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 2, 2019, 7:08am UTC](https://discuss.elastic.co/t/website-down-when-its-public-ip-why/184082/7 "2019-07-02T07:08:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
