# What is the best mix of index and shards on Elastic Cloud

**URL:** <https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896>\
**Category:** Elasticsearch\
**Created:** [June 24, 2021, 9:03am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896 "2021-06-24T09:03:55Z")\
**Posts on this page:** 11\
**Page:** 2

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [July 1, 2021, 1:53pm UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/21 "2021-07-01T13:53:57Z")

</div>

Did you try to restart Kibana?

Also You should open a support ticket.

---

<div class="post-metadata">

**Author:** ![kwoxer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kwoxer/32/74809_2.png) [@kwoxer](https://discuss.elastic.co/u/kwoxer)\
**Post date:** [July 2, 2021, 9:54am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/22 "2021-07-02T09:54:38Z")

</div>

Yes, but somehow the supporter is not able to help me.

Already upgraded to 4 GB RAM from 1 GB RAM. No change.

Also restarted Kibana. I think some index is broken from seeing the logs. But nothing I can do. Also tried to restore from a previous snapshot. But cant get away the internal error...

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [July 2, 2021, 2:27pm UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/23 "2021-07-02T14:27:29Z")

</div>

Did you add setting to your kibana.yml?  
When does that error occur?  
When you try to log in?  
When you try anonymous access?  
It looks like you may have tried to enable anonymous access ...

---

<div class="post-metadata">

**Author:** ![kwoxer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kwoxer/32/74809_2.png) [@kwoxer](https://discuss.elastic.co/u/kwoxer)\
**Post date:** [July 5, 2021, 5:01am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/24 "2021-07-05T05:01:34Z")

</div>

Did you add setting to your kibana.yml?

- no  
When does that error occur?
- any time I try to access Kibana  
When you try to log in?
- always via Browser?  
When you try anonymous access?
- it does not matter, any access fails  
It looks like you may have tried to enable anonymous access ...
- yes before I did changes to my indices everything worked also the anon access...

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [July 5, 2021, 7:05am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/25 "2021-07-05T07:05:48Z")

</div>

> [@kwoxer](#):
>
> Did you add setting to your kibana.yml?
> 
> - no

> [@kwoxer](#):
>
> - It looks like you may have tried to enable anonymous access ...
> - yes before I did changes to my indices everything worked also the anon access...

I am confused did you or did you not enable anonymous access?

I would try to clear all settings that you have put in your elasticsearch.yml and your kibana.yml.

And what do you mean support could not help you?

---

<div class="post-metadata">

**Author:** ![kwoxer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kwoxer/32/74809_2.png) [@kwoxer](https://discuss.elastic.co/u/kwoxer)\
**Post date:** [July 5, 2021, 7:13am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/26 "2021-07-05T07:13:34Z")

</div>

Indeed anon access was enabled.

No changes on elasticsearch.yml were done.

Removed now any custom changes on kibana.yml.

Well until now support only said upgrade the RAM, but that didn't help anything...

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [July 5, 2021, 3:45pm UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/27 "2021-07-05T15:45:26Z")

</div>

Now after you removed settings have you restarted Kibana?

Have you tried in a different browser or incognito window?

If those don't work I would set elasticsearch back to 4GB and reopen new ticket on Kibana issue.

---

<div class="post-metadata">

**Author:** ![kwoxer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kwoxer/32/74809_2.png) [@kwoxer](https://discuss.elastic.co/u/kwoxer)\
**Post date:** [July 6, 2021, 6:01am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/28 "2021-07-06T06:01:49Z")

</div>

Yes. Latest Chrome and Firefox Incognito. Same error:

```auto
login_form_LoginForm/<@https://xxx.kb.northeurope.azure.elastic-cloud.com:9243/40865/bundles/plugin/security/8.0.0/security.chunk.4.js:8:22270

```

The Kibana ticket exists since 5 days already:

 ![grafik](https://us1.discourse-cdn.com/elastic/original/3X/a/2/a22f9f464a97e8b91098470e601afc25ff5a22ba.png)

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [July 6, 2021, 2:06pm UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/29 "2021-07-06T14:06:26Z")

</div>

Your ticket is waiting on you.

You need to put in the error that you have there.

I would also open DevTools in Chrome and see if there's any errors there.

The steps you take to reproduce it in other words is that just when Kibana comes up or after you press the login button.

Include them all and be very specific about the error that you're having now.

---

<div class="post-metadata">

**Author:** ![kwoxer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kwoxer/32/74809_2.png) [@kwoxer](https://discuss.elastic.co/u/kwoxer)\
**Post date:** [July 12, 2021, 5:27am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/30 "2021-07-12T05:27:40Z")

</div>

Ok we solved it. There were somehow freezed indicies.

Unfreezed them with `POST insert_my_index/_unfreeze` and now working properly again.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2021, 5:27am UTC](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896/31 "2021-08-09T05:27:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

[Previous page](https://discuss.elastic.co/t/what-is-the-best-mix-of-index-and-shards-on-elastic-cloud/276896.md?page=1)
