# What is the hunspell version used by elasticsearch?

**URL:** <https://discuss.elastic.co/t/what-is-the-hunspell-version-used-by-elasticsearch/126224>\
**Category:** Elasticsearch\
**Created:** [March 30, 2018, 11:17am UTC](https://discuss.elastic.co/t/what-is-the-hunspell-version-used-by-elasticsearch/126224 "2018-03-30T11:17:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![stulentsev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stulentsev/32/29405_2.png) [@stulentsev](https://discuss.elastic.co/u/stulentsev)\
**Post date:** [March 30, 2018, 11:17am UTC](https://discuss.elastic.co/t/what-is-the-hunspell-version-used-by-elasticsearch/126224/1 "2018-03-30T11:17:14Z")

</div>

I'm trying to use a Dutch hunspell dictionary from LibreOffice: [nl\_NL.aff\nl\_NL - libreoffice/dictionaries - main, development dictionaries repository](https://cgit.freedesktop.org/libreoffice/dictionaries/tree/nl_NL/nl_NL.aff)

But it has this warning:

> BEWARE: THIS AFFIX FILE AND DICTIONARY REQUIRE HUNSPELL 1.2.8 AS MINIMAL VERSION

I can't create an index with this, so I assume elasticsearch 6.2.3 has a lower version of hunspell

```auto
Elasticsearch::Transport::Transport::Errors::InternalServerError: [500] {"error":{"root_cause":[{"type":"remote_transport_exception","reason":"[es-glossary-test-sergio-node-vm3][10.0.0.13:9300][indices:admin/create]"}],"type":"illegal_state_exception","reason":"failed to load hunspell dictionary for locale: nl_NL","caused_by":{"type":"illegal_argument_exception","reason":"expected only one flag, got: Kc"}},"status":500}

```

Does this error indeed mean that ES's hunspell is not modern enough? If yes, can I update it? If not, why wouldn't it work?

---

<div class="post-metadata">

**Author:** ![stulentsev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stulentsev/32/29405_2.png) [@stulentsev](https://discuss.elastic.co/u/stulentsev)\
**Post date:** [March 30, 2018, 12:38pm UTC](https://discuss.elastic.co/t/what-is-the-hunspell-version-used-by-elasticsearch/126224/2 "2018-03-30T12:38:29Z")

</div>

This workaround fixes it for me: [Dutch hunspell doesn't work in 1.7.1?](https://discuss.elastic.co/t/dutch-hunspell-doesnt-work-in-1-7-1/28440/4)

"Fixes" in the sense "ES can now create the index". Didn't yet check if it's actually doing what it should. 🙂

Still, it'd be nice if it "just worked".

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 27, 2018, 12:38pm UTC](https://discuss.elastic.co/t/what-is-the-hunspell-version-used-by-elasticsearch/126224/3 "2018-04-27T12:38:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
