# What's the cause and the solution of this problem plz

**URL:** <https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269>\
**Category:** Elasticsearch\
**Created:** [August 30, 2022, 5:03pm UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269 "2022-08-30T17:03:49Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [August 30, 2022, 5:03pm UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269/1 "2022-08-30T17:03:49Z")

</div>

I installed elasticsearch and kibana 8.4.0 in the same ubuntu 22.04 VM and i try to connect them by token and when i try to create a token i get this error help plz and thanks

```auto
kibana@kibana:/usr/share/elasticsearch/bin$ ./elasticsearch-create-enrollment-token -s kibana
./elasticsearch-env: line 78: /etc/default/elasticsearch: Permission denied
kibana@kibana:/usr/share/elasticsearch/bin$ sudo ./elasticsearch-create-enrollment-token -s kibana
17:02:36.334 [main] ERROR org.elasticsearch.xpack.security.enrollment.ExternalEnrollmentTokenGenerator - Error 429when calling GET https://192.168.43.157:9200/_security/api_key. ResponseBody: {error={reason=index [.security-7] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];, type=cluster_block_exception, root_cause=[{reason=index [.security-7] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];, type=cluster_block_exception}]}, status=429}
Unable to create enrollment token for scope [kibana]

ERROR: Unexpected response code [429] from calling POST https://192.168.43.157:9200/_security/api_key

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 30, 2022, 9:37pm UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269/2 "2022-08-30T21:37:20Z")

</div>

> [@morad\_della3](#):
>
> `disk usage exceeded flood-stage watermark`

Your node is running out of disk space.

---

<div class="post-metadata">

**Author:** ![cheshirecat](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cheshirecat/32/109532_2.png) [@cheshirecat](https://discuss.elastic.co/u/cheshirecat)\
**Post date:** [August 31, 2022, 9:01am UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269/3 "2022-08-31T09:01:17Z")

</div>

There is second answer: Elasticsearch 'thinks' there is no space left. I had this issue. There was plenty of free space (about 60% of the volume).

[Docs](https://www.elastic.co/guide/en/elasticsearch/reference/master/disk-usage-exceeded.html) are here.

---

<div class="post-metadata">

**Author:** ![morad\_della3](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/morad_della3/32/101241_2.png) [@morad\_della3](https://discuss.elastic.co/u/morad_della3)\
**Post date:** [August 31, 2022, 9:05am UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269/4 "2022-08-31T09:05:05Z")

</div>

thanks @cheshirecat for your info , do you have any idea of this prob plz [What's the cause of this prob and what's the solution - #3 by morad\_della3](https://discuss.elastic.co/t/whats-the-cause-of-this-prob-and-whats-the-solution/313086/3)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 28, 2022, 9:05am UTC](https://discuss.elastic.co/t/whats-the-cause-and-the-solution-of-this-problem-plz/313269/5 "2022-09-28T09:05:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
